CVE-2026-48204 Apache Camel: camel-mongodb-gridfs producer allows GridFS operation override and NoSQL operator injection via unfiltered gridfs.* HTTP headers

Critical 9.8 Published Updated

Attackers can manipulate HTTP headers to override GridFS operations, enabling unauthorized file deletion, enumeration, or reading in default configurations.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-48204?

CVE-2026-48204 is a critical missing authorization vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Input Validation, Improper Access Control vulnerability in Apache Camel in Camel Mongodb Gridfs component.

The camel-mongodb-gridfs producer selects the GridFS operation to perform from the gridfs.operation Exchange header when the endpoint's operation parameter is not set - which is the default. The control-header constants (GridFsConstants.GRIDFS_OPERATION, GRIDFS_OBJECT_ID, GRIDFS_METADATA, GRIDFS_CHUNKSIZE, GRIDFS_FILE_ID_PRODUCED) were the plain strings gridfs.operation, gridfs.objectid, gridfs.metadata, gridfs.chunksize and gridfs.fileid. Because these names do not start with the Camel / camel prefix, HttpHeaderFilterStrategy - which blocks only the Camel header namespace on the HTTP boundary - let them pass from an inbound HTTP request straight into the Exchange. In a route that bridges an HTTP consumer (for example platform-http) into a mongodb-gridfs: producer with no explicit operation, any HTTP client could therefore set the gridfs.operation header to override the route's intended operation - switching, for example, a file upload to remove (deleting a file identified by the attacker-supplied gridfs.objectid), listAll (enumerating every file in the bucket) or findOne (reading a file) - and supply a gridfs.metadata value that is parsed as a MongoDB document, enabling NoSQL operator injection. No credentials are required when the bridging consumer is unauthenticated. This issue affects Apache Camel: from 4.0.0 before 4.14.8, from 4.15.0 before 4.18.3, from 4.19.0 before 4.21.0.

Users are recommended to upgrade to version 4.21.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.8. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.3. After upgrading, routes that drive GridFS operations or metadata via the raw header names must use CamelGridFsOperation / CamelGridFsObjectId / CamelGridFsMetadata / CamelGridFsChunkSize / CamelGridFsFileId instead of the gridfs.* names. For deployments that cannot upgrade immediately, set an explicit operation on the mongodb-gridfs: endpoint so the operation is not taken from a header, and strip the gridfs.* headers from any untrusted ingress before the producer.

Weakness: CWE-284, CWE-20

Which versions are affected by CVE-2026-48204?

6 open source packages ship an affected version, including org.apache.camel:camel-mongodb-gridfs. It affects 1 product.

PackageAffectedFixed in
org.apache.camel:camel-mongodb-gridfs MavenFrom 4.0.04.14.8
org.apache.camel:camel-mongodb-gridfs MavenFrom 4.0.04.14.8
org.apache.camel:camel-mongodb-gridfs MavenFrom 4.15.04.18.3
org.apache.camel:camel-mongodb-gridfs MavenFrom 4.15.04.18.3
org.apache.camel:camel-mongodb-gridfs MavenFrom 4.19.04.21.0
org.apache.camel:camel-mongodb-gridfs MavenFrom 4.19.04.21.0

Products include Apache Camel.

How do I fix CVE-2026-48204?

Upgrade org.apache.camel:camel-mongodb-gridfs to a fixed version for your release line: 4.14.8, 4.18.3 or 4.21.0.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-48204 being exploited?

There is no known exploitation of CVE-2026-48204 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Apache Camel vulnerabilities

Sources

Also known as GHSA-f7g3-2cg6-f5hj.

Is CVE-2026-48204 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free