# CVE-2026-48204: Apache Camel: camel-mongodb-gridfs producer allows GridFS operation override and NoSQL operator injection via unfiltered gridfs.* HTTP headers

> Attackers can manipulate HTTP headers to override GridFS operations, enabling unauthorized file deletion, enumeration, or reading in default configurations.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-f7g3-2cg6-f5hj

## What is CVE-2026-48204?

CVE-2026-48204 is a critical missing authorization vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation, Improper Access Control vulnerability in Apache Camel in Camel Mongodb Gridfs component.

The camel-mongodb-gridfs producer selects the GridFS operation to perform from the gridfs.operation Exchange header when the endpoint's operation parameter is not set - which is the default. The control-header constants (GridFsConstants.GRIDFS_OPERATION, GRIDFS_OBJECT_ID, GRIDFS_METADATA, GRIDFS_CHUNKSIZE, GRIDFS_FILE_ID_PRODUCED) were the plain strings gridfs.operation, gridfs.objectid, gridfs.metadata, gridfs.chunksize and gridfs.fileid. Because these names do not start with the Camel / camel prefix, HttpHeaderFilterStrategy - which blocks only the Camel header namespace on the HTTP boundary - let them pass from an inbound HTTP request straight into the Exchange. In a route that bridges an HTTP consumer (for example platform-http) into a mongodb-gridfs: producer with no explicit operation, any HTTP client could therefore set the gridfs.operation header to override the route's intended operation - switching, for example, a file upload to remove (deleting a file identified by the attacker-supplied gridfs.objectid), listAll (enumerating every file in the bucket) or findOne (reading a file) - and supply a gridfs.metadata value that is parsed as a MongoDB document, enabling NoSQL operator injection. No credentials are required when the bridging consumer is unauthenticated.
This issue affects Apache Camel: from 4.0.0 before 4.14.8, from 4.15.0 before 4.18.3, from 4.19.0 before 4.21.0.

Users are recommended to upgrade to version 4.21.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.8. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.3. After upgrading, routes that drive GridFS operations or metadata via the raw header names must use CamelGridFsOperation / CamelGridFsObjectId / CamelGridFsMetadata / CamelGridFsChunkSize / CamelGridFsFileId instead of the gridfs.* names. For deployments that cannot upgrade immediately, set an explicit operation on the mongodb-gridfs: endpoint so the operation is not taken from a header, and strip the gridfs.* headers from any untrusted ingress before the producer.

Weakness: CWE-284 (Improper Access Control), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-48204?

6 open source packages ship an affected version, including org.apache.camel:camel-mongodb-gridfs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-mongodb-gridfs` | Maven | From 4.0.0 | 4.14.8 |
| `org.apache.camel:camel-mongodb-gridfs` | Maven | From 4.0.0 | 4.14.8 |
| `org.apache.camel:camel-mongodb-gridfs` | Maven | From 4.15.0 | 4.18.3 |
| `org.apache.camel:camel-mongodb-gridfs` | Maven | From 4.15.0 | 4.18.3 |
| `org.apache.camel:camel-mongodb-gridfs` | Maven | From 4.19.0 | 4.21.0 |
| `org.apache.camel:camel-mongodb-gridfs` | Maven | From 4.19.0 | 4.21.0 |

Products: Apache Camel.

## How do I fix CVE-2026-48204?

Upgrade org.apache.camel:camel-mongodb-gridfs to a fixed version for your release line: 4.14.8, 4.18.3 or 4.21.0.

## Is CVE-2026-48204 being exploited?

There is no known exploitation of CVE-2026-48204 in the wild and no public exploit code.

Public exploit code:

- Reproducer for CVE-2026-48204: Apache Camel camel-mongodb-gridfs gridfs.* header injection overriding the GridFS operation (enumerate/read/delete files) from an unauthenticated HTTP request (fixed in 4.14.8/4.18.3/4.21.0) (github_poc): https://github.com/oscerd/CVE-2026-48204

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48204 and fix it if it is affected.

What it is: CVE-2026-48204 is a critical missing authorization vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48204 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-mongodb-gridfs (Maven): affected from 4.0.0; fixed in 4.14.8
- org.apache.camel:camel-mongodb-gridfs (Maven): affected from 4.0.0; fixed in 4.14.8
- org.apache.camel:camel-mongodb-gridfs (Maven): affected from 4.15.0; fixed in 4.18.3
- org.apache.camel:camel-mongodb-gridfs (Maven): affected from 4.15.0; fixed in 4.18.3
- org.apache.camel:camel-mongodb-gridfs (Maven): affected from 4.19.0; fixed in 4.21.0
- org.apache.camel:camel-mongodb-gridfs (Maven): affected from 4.19.0; fixed in 4.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48204/ (Markdown: https://insights.sbomify.com/CVE-2026-48204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48204
- OSV: https://osv.dev/vulnerability/CVE-2026-48204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48204/
Summaries are generated and may contain mistakes; the official description above is the record.
