{"answers":{"affected":"3 open source packages ship an affected version, including pyfory. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-48207 in the wild and no public exploit code.","fix":"Upgrade pyfory to 1.0.0 or later.","what":"CVE-2026-48207 is a critical unsafe deserialization vulnerability in Apache Fory, published on 21 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-48207 and fix it if it is affected.\n\nWhat it is: CVE-2026-48207 is a critical unsafe deserialization vulnerability in Apache Fory, published on 21 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-48207 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pyfory (PyPI): affected from 0.13.0; fixed in 1.0.0\n- pyfory (PyPI): affected from 0.13.0; fixed in 1.0.0\n- pyfory (PyPI): affected from 0.13.0; fixed in 1.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-48207/ (Markdown: https://insights.sbomify.com/CVE-2026-48207/index.md)","id":"CVE-2026-48207","markdown":"https://insights.sbomify.com/CVE-2026-48207/index.md","name":"CVE-2026-48207","record":{"aliases":["GHSA-m5gw-83w2-7749","PYSEC-2026-2984"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Python serialization library","requires_auth":"none","summary":"Attackers can execute arbitrary code by bypassing security policies during deserialization in PyFory when strict mode is disabled.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"fory","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Deserialization of untrusted data in Apache Fory PyFory. PyFory's ReduceSerializer could bypass documented DeserializationPolicy validation hooks during reduce-state restoration and global-name resolution. An application is vulnerable if it deserializes attacker-controlled data using PyFory Python-native mode with strict mode disabled and relies on DeserializationPolicy to restrict unsafe classes, functions, or module attributes.\n\nThis issue affects Apache Fory: from before 1.0.0.\n\nMitigation: Users of Apache Fory are recommended to upgrade to version 1.0.0 or later, which enforces DeserializationPolicy validation for the affected ReduceSerializer paths and thus fixes this issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Fory: PyFory ReduceSerializer Incomplete Policy Enforcement","id":"CVE-2026-48207","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":3,"n_references":1,"next":{"headline":"Denial-of-Service via SVG Rendering in Ticket","id":"CVE-2026-48208"},"packages":[{"ecosystem":"PyPI","fixed":["1.0.0"],"introduced":["0.13.0"],"last_affected":[],"package":"pyfory","purl":null,"source":"GHSA-m5gw-83w2-7749"},{"ecosystem":"PyPI","fixed":["1.0.0"],"introduced":["0.13.0"],"last_affected":[],"package":"pyfory","purl":"pkg:pypi/pyfory","source":"GHSA-m5gw-83w2-7749"},{"ecosystem":"PyPI","fixed":["1.0.0"],"introduced":["0.13.0"],"last_affected":[],"package":"pyfory","purl":"pkg:pypi/pyfory","source":"PYSEC-2026-2984"}],"prev":{"headline":"Apache Camel-JIRA: A set of non-Camel-prefixed Exchange header constants bypass the HTTP header filter","id":"CVE-2026-48206"},"products":["Apache Fory"],"published":"2026-05-21","related":[{"cvss_score":9.8,"headline":"Apache Fory: Heap type confusion in C++ polymorphic smart-pointer deserialization","id":"CVE-2026-71558","kev_date_added":null,"published":"2026-08-07"},{"cvss_score":9.8,"headline":"Apache Fory, Apache Fory: Class-registration bypass through an auto-admitted SerializedLambda capturing interface","id":"CVE-2026-64606","kev_date_added":null,"published":"2026-07-21"},{"cvss_score":9.8,"headline":"Apache Fory: Heap type confusion and out-of-bounds read/write in C++ compatible-mode field-skip paths","id":"CVE-2026-64608","kev_date_added":null,"published":"2026-07-21"},{"cvss_score":9.8,"headline":"Apache Fory, Apache Fory: Python RCE via unguarded pickle fallback serializer in pyfory","id":"CVE-2025-61622","kev_date_added":null,"published":"2025-10-01"},{"cvss_score":9.1,"headline":"Apache Fory: Out-of-bounds heap read in C++ struct deserializer tagged-int fast-path","id":"CVE-2026-71560","kev_date_added":null,"published":"2026-08-07"},{"cvss_score":9.1,"headline":"Apache Fory, Apache Fory: Out-of-Bounds Read via sun.misc.Unsafe in zero-copy java deserialization","id":"CVE-2026-64609","kev_date_added":null,"published":"2026-07-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-21","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary code by bypassing security policies during deserialization in PyFory when strict mode is disabled.","url":"https://insights.sbomify.com/CVE-2026-48207/"}