# CVE-2026-48207: Apache Fory: PyFory ReduceSerializer Incomplete Policy Enforcement

> Attackers can execute arbitrary code by bypassing security policies during deserialization in PyFory when strict mode is disabled.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 May 2026
- **Updated:** 21 May 2026
- **Also known as:** GHSA-m5gw-83w2-7749, PYSEC-2026-2984

## What is CVE-2026-48207?

CVE-2026-48207 is a critical unsafe deserialization vulnerability in Apache Fory, published on 21 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deserialization of untrusted data in Apache Fory PyFory. PyFory's ReduceSerializer could bypass documented DeserializationPolicy validation hooks during reduce-state restoration and global-name resolution. An application is vulnerable if it deserializes attacker-controlled data using PyFory Python-native mode with strict mode disabled and relies on DeserializationPolicy to restrict unsafe classes, functions, or module attributes.

This issue affects Apache Fory: from before 1.0.0.

Mitigation: Users of Apache Fory are recommended to upgrade to version 1.0.0 or later, which enforces DeserializationPolicy validation for the affected ReduceSerializer paths and thus fixes this issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-48207?

3 open source packages ship an affected version, including pyfory. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyfory` | PyPI | From 0.13.0 | 1.0.0 |
| `pyfory` | PyPI | From 0.13.0 | 1.0.0 |
| `pyfory` | PyPI | From 0.13.0 | 1.0.0 |

Products: Apache Fory.

## How do I fix CVE-2026-48207?

Upgrade pyfory to 1.0.0 or later.

## Is CVE-2026-48207 being exploited?

There is no known exploitation of CVE-2026-48207 in the wild and no public exploit code.

## Other vulnerabilities in Apache Fory

- [CVE-2026-71558](https://insights.sbomify.com/CVE-2026-71558/): Apache Fory: Heap type confusion in C++ polymorphic smart-pointer deserialization (critical 9.8)
- [CVE-2026-64606](https://insights.sbomify.com/CVE-2026-64606/): Apache Fory, Apache Fory: Class-registration bypass through an auto-admitted SerializedLambda capturing interface (critical 9.8)
- [CVE-2026-64608](https://insights.sbomify.com/CVE-2026-64608/): Apache Fory: Heap type confusion and out-of-bounds read/write in C++ compatible-mode field-skip paths (critical 9.8)
- [CVE-2025-61622](https://insights.sbomify.com/CVE-2025-61622/): Apache Fory, Apache Fory: Python RCE via unguarded pickle fallback serializer in pyfory (critical 9.8)
- [CVE-2026-71560](https://insights.sbomify.com/CVE-2026-71560/): Apache Fory: Out-of-bounds heap read in C++ struct deserializer tagged-int fast-path (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48207 and fix it if it is affected.

What it is: CVE-2026-48207 is a critical unsafe deserialization vulnerability in Apache Fory, published on 21 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48207 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyfory (PyPI): affected from 0.13.0; fixed in 1.0.0
- pyfory (PyPI): affected from 0.13.0; fixed in 1.0.0
- pyfory (PyPI): affected from 0.13.0; fixed in 1.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48207/ (Markdown: https://insights.sbomify.com/CVE-2026-48207/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48207
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48207
- OSV: https://osv.dev/vulnerability/CVE-2026-48207

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48207/
Summaries are generated and may contain mistakes; the official description above is the record.
