# CVE-2026-48484: pyLoad: Lack of Input Size Validation Leads to Denial of Service (DoS) and Process Termination

> Attackers can crash the pyLoad download manager by uploading large files, exhausting server memory due to missing input size validation.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Oct 2026
- **Updated:** 14 Oct 2026
- **Also known as:** GHSA-vq8p-m3wm-gv5f, PYSEC-2026-4293

## What is CVE-2026-48484?

CVE-2026-48484 is a medium-severity denial of service vulnerability in pyload, published on 9 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

pyLoad is a free and open-source download manager written in Python. Prior to 0.5.0b3.dev101, the API `rpc` function in `api_blueprint.py` handles `multipart/form-data` uploads by reading the whole content of the uploaded file into memory with `file.read()`. This occurs before the data is sent to the underlying function. Since there is no size limit set at this point, a large file upload can exhaust the server's available memory which led to process termination. Version 0.5.0b3.dev101 contains a patch.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-48484?

3 open source packages ship an affected version, including pyload-ng.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev101 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev101 |
| `pyload-ng` | PyPI | All versions | 0.5.0b3.dev101 |

## How do I fix CVE-2026-48484?

Upgrade pyload-ng to 0.5.0b3.dev101 or later.

## Is CVE-2026-48484 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48484 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48484 and fix it if it is affected.

What it is: CVE-2026-48484 is a medium-severity denial of service vulnerability in pyload, published on 9 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48484 exists.

Affected packages and fixed versions:
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev101
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev101
- pyload-ng (PyPI): affected all versions; fixed in 0.5.0b3.dev101

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48484/ (Markdown: https://insights.sbomify.com/CVE-2026-48484/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48484
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48484
- OSV: https://osv.dev/vulnerability/CVE-2026-48484

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48484/
Summaries are generated and may contain mistakes; the official description above is the record.
