# CVE-2026-48488: phpMyFAQ has Weak Cryptography - SHA1 for Password Hashing

> Attackers can potentially recover attachment passwords due to the use of the broken SHA-1 hashing algorithm in phpMyFAQ.

- **Severity:** Low 2.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jun 2026
- **Updated:** 9 Jun 2026
- **Also known as:** GHSA-58fg-62fg-3fcj

## What is CVE-2026-48488?

CVE-2026-48488 is a low-severity vulnerability in thorsten phpMyFAQ, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

phpMyFAQ is an open source FAQ web application. Prior to version 4.1.4, attachment passwords are hashed using SHA-1, a cryptographically broken algorithm. SHA-1 has been vulnerable to collision attacks since 2017 (SHAttered). Version 4.1.4 fixes the issue.

Weakness: CWE-328 (Use of Weak Hash)

## Which versions are affected by CVE-2026-48488?

4 open source packages ship an affected version, including thorsten/phpmyfaq and phpmyfaq/phpmyfaq.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.4 |
| `thorsten/phpmyfaq` | Packagist | All versions | 4.1.4 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.4 |
| `phpmyfaq/phpmyfaq` | Packagist | All versions | 4.1.4 |

## How do I fix CVE-2026-48488?

Upgrade thorsten/phpmyfaq to 4.1.4 or later.

## Is CVE-2026-48488 being exploited?

There is no known exploitation of CVE-2026-48488 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48488 and fix it if it is affected.

What it is: CVE-2026-48488 is a low-severity vulnerability in thorsten phpMyFAQ, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48488 in the wild and no public exploit code.

Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.4
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 4.1.4
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.4
- phpmyfaq/phpmyfaq (Packagist): affected all versions; fixed in 4.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48488/ (Markdown: https://insights.sbomify.com/CVE-2026-48488/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48488
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48488
- OSV: https://osv.dev/vulnerability/CVE-2026-48488

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48488/
Summaries are generated and may contain mistakes; the official description above is the record.
