# CVE-2026-48489: Symfony: Security Firewall Bypass via failure_forward Subrequest: Unauthenticated Access to access_control-Protected GET Routes

> An attacker can bypass authentication to access protected GET routes by exploiting a subrequest flaw in the default authentication failure handler.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 16 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-48489, GHSA-6h46-9jf5-q59x, UBUNTU-CVE-2026-48489

## What is CVE-2026-48489?

CVE-2026-48489 is a high-severity authentication bypass vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.53, 6.4.41, 7.4.13, and 8.0.13, DefaultAuthenticationFailureHandler honored the request-supplied _failure_path parameter when failure_forward: true was enabled, allowing an unauthenticated failing login request to dispatch a subrequest to access_control-protected GET routes that skipped firewall listeners. This issue is fixed in versions 5.4.53, 6.4.41, 7.4.13, and 8.0.13.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-48489?

16 open source packages ship an affected version, including symfony/security-http and symfony/symfony. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/security-http` | Packagist | All versions | 5.4.53 |
| `symfony/security-http` | Packagist | All versions | 5.4.53 |
| `symfony/security-http` | Packagist | From 6.0.0 | 6.4.41 |
| `symfony/security-http` | Packagist | From 6.0.0 | 6.4.41 |
| `symfony/security-http` | Packagist | From 7.0.0 | 7.4.13 |
| `symfony/security-http` | Packagist | From 7.0.0 | 7.4.13 |
| `symfony/security-http` | Packagist | From 8.0.0 | 8.0.13 |
| `symfony/security-http` | Packagist | From 8.0.0 | 8.0.13 |
| `symfony/symfony` | Packagist | All versions | 5.4.53 |
| `symfony/symfony` | Packagist | All versions | 5.4.53 |
| `symfony/symfony` | Packagist | From 6.0.0 | 6.4.41 |
| `symfony/symfony` | Packagist | From 6.0.0 | 6.4.41 |
| `symfony/symfony` | Packagist | From 7.0.0 | 7.4.13 |
| `symfony/symfony` | Packagist | From 7.0.0 | 7.4.13 |
| `symfony/symfony` | Packagist | From 8.0.0 | 8.0.13 |
| `symfony/symfony` | Packagist | From 8.0.0 | 8.0.13 |

Products: Sensiolabs Symfony.

## How do I fix CVE-2026-48489?

Upgrade symfony/security-http to a fixed version for your release line: 5.4.53, 6.4.41, 7.4.13 or 8.0.13.

## Is CVE-2026-48489 being exploited?

There is no known exploitation of CVE-2026-48489 in the wild and no public exploit code.

## Other vulnerabilities in Sensiolabs Symfony

- [CVE-2019-11325](https://insights.sbomify.com/CVE-2019-11325/): Improper Input Validation in Symfony (critical 9.8)
- [CVE-2017-11365](https://insights.sbomify.com/CVE-2017-11365/): Symfony Incorrect Access Control (critical 9.8)
- [CVE-2019-10913](https://insights.sbomify.com/CVE-2019-10913/): Invalid HTTP method overrides allow possible XSS or other attacks in Symfony (critical 9.8)
- [CVE-2018-11407](https://insights.sbomify.com/CVE-2018-11407/): Symfony Authentication Bypass (critical 9.8)
- [CVE-2016-2403](https://insights.sbomify.com/CVE-2016-2403/): Symfony Authentication Bypass (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48489 and fix it if it is affected.

What it is: CVE-2026-48489 is a high-severity authentication bypass vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48489 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/security-http (Packagist): affected all versions; fixed in 5.4.53
- symfony/security-http (Packagist): affected all versions; fixed in 5.4.53
- symfony/security-http (Packagist): affected from 6.0.0; fixed in 6.4.41
- symfony/security-http (Packagist): affected from 6.0.0; fixed in 6.4.41
- symfony/security-http (Packagist): affected from 7.0.0; fixed in 7.4.13
- symfony/security-http (Packagist): affected from 7.0.0; fixed in 7.4.13
- symfony/security-http (Packagist): affected from 8.0.0; fixed in 8.0.13
- symfony/security-http (Packagist): affected from 8.0.0; fixed in 8.0.13
- symfony/symfony (Packagist): affected all versions; fixed in 5.4.53
- symfony/symfony (Packagist): affected all versions; fixed in 5.4.53
- symfony/symfony (Packagist): affected from 6.0.0; fixed in 6.4.41
- symfony/symfony (Packagist): affected from 6.0.0; fixed in 6.4.41

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48489/ (Markdown: https://insights.sbomify.com/CVE-2026-48489/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48489
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48489
- OSV: https://osv.dev/vulnerability/CVE-2026-48489

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48489/
Summaries are generated and may contain mistakes; the official description above is the record.
