CVE-2026-48493 Snipe-IT Vulnerable to Privilege Escalation for self via API Permissions Assignment
A user with edit permissions can escalate privileges via API to gain unauthorized access to assets and reports.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-48493?
CVE-2026-48493 is a medium-severity vulnerability in Snipeitapp Snipe-It, published on 23 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Snipe-IT is an IT asset/license management system. In versions prior to 8.6.0, a user with only users.edit can send a PATCH to /api/v1/users/{their_own_id} and grant themselves any permission except admin and superuser — for example `assets.view`, `assets.create`, `reports.view`, import, etc. The issue is patched in version 8.6.0.
Weakness: CWE-863
Which versions are affected by CVE-2026-48493?
2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
snipe/snipe-it Packagist | All versions | 8.6.0 |
snipe/snipe-it Packagist | All versions | 8.6.0 |
Products include Snipeitapp Snipe-It.
How do I fix CVE-2026-48493?
Upgrade snipe/snipe-it to 8.6.0 or later.
Is CVE-2026-48493 being exploited?
There is no known exploitation of CVE-2026-48493 in the wild and no public exploit code.
Other vulnerabilities in Snipeitapp Snipe-It
- CVE-2025-63601 File upload in n/a
- CVE-2026-37709 Snipe-IT has insecure permissions in file uploads
- CVE-2026-86738 Snipe-IT before 8.7.0 CSS Injection via Custom CSS
- CVE-2026-116199 Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback
- CVE-2022-1380 Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it
Sources
Also known as GHSA-52fw-7fw2-fmv5.