CVE-2026-48512 MessagePack-CSharp: JSON conversion APIs can recurse without consistent depth enforcement

Medium 6.3 Published Updated

Attackers can cause a stack overflow and crash the application by sending deeply nested or malformed JSON to MessagePack-CSharp's conversion APIs.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-48512?

CVE-2026-48512 is a medium-severity denial of service vulnerability in MessagePack-CSharp, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

MessagePack for C# is a MessagePack serializer for C#. Prior to 2.5.301 and 3.1.7, MessagePack-CSharp's JSON conversion helpers contain multiple recursion paths that do not consistently enforce a depth limit. These paths are in the JSON conversion component rather than normal typed MessagePack deserialization. MessagePackSerializer.ConvertFromJson recursively processes nested JSON arrays and objects in FromJsonCore() without consulting MessagePackSecurity.MaximumObjectGraphDepth. TinyJsonReader.ReadNextToken() recursively consumes comma and colon separator characters, allowing even malformed JSON with long separator runs to consume one stack frame per character. MessagePackSerializer.ConvertToJson applies depth checks to arrays and maps, but the typeless extension branch for ext-100 recursively calls ToJsonCore() without applying MessagePackSecurity.DepthStep(ref reader). Each path can allow attacker-controlled input to exhaust the process stack and trigger an uncatchable StackOverflowException instead of failing with a catchable parse or serialization exception. This vulnerability is fixed in 2.5.301 and 3.1.7.

Weakness: CWE-674

Which versions are affected by CVE-2026-48512?

4 open source packages ship an affected version, including MessagePack. It affects 1 product.

PackageAffectedFixed in
MessagePack NuGetAll versions2.5.301
MessagePack NuGetAll versions2.5.301
MessagePack NuGetFrom 3.03.1.7
MessagePack NuGetFrom 3.03.1.7

Products include Messagepack Messagepack.

How do I fix CVE-2026-48512?

Upgrade MessagePack to a fixed version for your release line: 2.5.301 or 3.1.7.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-48512 being exploited?

There is no known exploitation of CVE-2026-48512 in the wild and no public exploit code.

Sources

Also known as ECHO-1db0-dd7e-7fae, GHSA-cj9g-3mj2-g8vv.

Is CVE-2026-48512 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free