CVE-2026-48527 HaxCMS has a stored Cross-Site Scripting (XSS) bypass in saveNode endpoint
Authenticated users can bypass HTML sanitization in HaxCMS to inject malicious scripts via the saveNode endpoint, potentially leading to code execution or account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-48527?
CVE-2026-48527 is a high-severity cross-site scripting vulnerability in haxtheweb haxcms-nodejs, published on 29 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
HAX CMS helps manage microsite universe with PHP or NodeJs backends. Versions up to and including 26.0.0 are affected by a stored cross-site scripting (XSS) vulnerability in the `/system/api/saveNode` endpoint. An authenticated user with a permission to edit pages can bypass the HTML sanitizer by injecting an event handler attribute without whitespace before the attribute name. @haxtheweb/haxcms-nodejs 26.0.1 and haxcms-php 26.0.2 patch the issue.
Weakness: CWE-79
Which versions are affected by CVE-2026-48527?
2 open source packages ship an affected version, including @haxtheweb/haxcms-nodejs.
| Package | Affected | Fixed in |
|---|---|---|
@haxtheweb/haxcms-nodejs npm | All versions | 26.0.1 |
@haxtheweb/haxcms-nodejs npm | All versions | 26.0.1 |
How do I fix CVE-2026-48527?
Upgrade @haxtheweb/haxcms-nodejs to 26.0.1 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-48527 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48527 exists.
Sources
Also known as GHSA-g2g8-95qg-v35h.