# CVE-2026-48527: HaxCMS has a stored Cross-Site Scripting (XSS) bypass in saveNode endpoint

> Authenticated users can bypass HTML sanitization in HaxCMS to inject malicious scripts via the saveNode endpoint, potentially leading to code execution or account takeover.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 29 May 2026
- **Also known as:** GHSA-g2g8-95qg-v35h

## What is CVE-2026-48527?

CVE-2026-48527 is a high-severity cross-site scripting vulnerability in haxtheweb haxcms-nodejs, published on 29 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

HAX CMS helps manage microsite universe with PHP or NodeJs backends. Versions up to and including 26.0.0 are affected by a stored cross-site scripting (XSS) vulnerability in the `/system/api/saveNode` endpoint. An authenticated user with a permission to edit pages can bypass the HTML sanitizer by injecting an event handler attribute without whitespace before the attribute name. @haxtheweb/haxcms-nodejs 26.0.1 and haxcms-php 26.0.2 patch the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-48527?

2 open source packages ship an affected version, including @haxtheweb/haxcms-nodejs.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@haxtheweb/haxcms-nodejs` | npm | All versions | 26.0.1 |
| `@haxtheweb/haxcms-nodejs` | npm | All versions | 26.0.1 |

## How do I fix CVE-2026-48527?

Upgrade @haxtheweb/haxcms-nodejs to 26.0.1 or later.

## Is CVE-2026-48527 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48527 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48527 and fix it if it is affected.

What it is: CVE-2026-48527 is a high-severity cross-site scripting vulnerability in haxtheweb haxcms-nodejs, published on 29 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48527 exists.

Affected packages and fixed versions:
- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 26.0.1
- @haxtheweb/haxcms-nodejs (npm): affected all versions; fixed in 26.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48527/ (Markdown: https://insights.sbomify.com/CVE-2026-48527/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48527
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48527
- OSV: https://osv.dev/vulnerability/CVE-2026-48527

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48527/
Summaries are generated and may contain mistakes; the official description above is the record.
