# CVE-2026-48529: GitHub MCP Server: Lockdown mode singleton in HTTP server causes cross-user GraphQL client confusion

> In HTTP lockdown mode, a singleton cache causes subsequent users' requests to execute using the first user's credentials, allowing unauthorized access.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2026
- **Updated:** 27 Jun 2026
- **Also known as:** GHSA-pjp5-fpmr-3349, GO-2026-5779

## What is CVE-2026-48529?

CVE-2026-48529 is a medium-severity authentication bypass vulnerability in github-mcp-server, published on 26 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GitHub MCP Server is GitHub's official MCP Server. From 0.22.0 until 1.1.2, when running in HTTP mode with --lockdown-mode enabled, the RepoAccessCache is implemented as a process-global singleton initialized with the first authenticated user's GraphQL client. All subsequent requests from different users share this singleton and their lockdown-related GraphQL queries are executed using the first user's credentials. The singleton is never updated to reflect later users' tokens. This vulnerability is fixed in 1.1.2.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-48529?

3 open source packages ship an affected version, including github.com/github/github-mcp-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/github/github-mcp-server` | Go | From 0.22.0 | 1.1.2 |
| `github.com/github/github-mcp-server` | Go | From 0.22.0 | 1.1.2 |
| `github.com/github/github-mcp-server` | Go | From 0.22.0 | 1.1.2 |

## How do I fix CVE-2026-48529?

Upgrade github.com/github/github-mcp-server to 1.1.2 or later.

## Is CVE-2026-48529 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48529 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48529 and fix it if it is affected.

What it is: CVE-2026-48529 is a medium-severity authentication bypass vulnerability in github-mcp-server, published on 26 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48529 exists.

Affected packages and fixed versions:
- github.com/github/github-mcp-server (Go): affected from 0.22.0; fixed in 1.1.2
- github.com/github/github-mcp-server (Go): affected from 0.22.0; fixed in 1.1.2
- github.com/github/github-mcp-server (Go): affected from 0.22.0; fixed in 1.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48529/ (Markdown: https://insights.sbomify.com/CVE-2026-48529/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48529
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48529
- OSV: https://osv.dev/vulnerability/CVE-2026-48529

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48529/
Summaries are generated and may contain mistakes; the official description above is the record.
