# CVE-2026-48557: Spatie Laravel Media Library < 11.23.0 File Upload Restriction Bypass via FileAdder.php

> Attackers can bypass file upload restrictions to upload malicious files, potentially achieving code execution if server configurations allow it.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-3ggm-c5m7-hfv5

## What is CVE-2026-48557?

CVE-2026-48557 is a high-severity vulnerability in spatie laravel-medialibrary, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Spatie Laravel Media Library before version 11.23.0 contains a file upload restriction bypass in FileAdder::defaultSanitizer(). The sanitizer checks only the final filename suffix, allowing double-extension filenames such as shell.php.jpg to bypass the blocklist, with pathinfo() preserving inner .php stems in saved filenames. The blocklist also omits executable extensions including .php6, .shtml, and .htaccess. The double-extension bypass requires a legacy Apache AddHandler configuration to achieve PHP execution; the incomplete blocklist bypass does not.

Weakness: CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2026-48557?

2 open source packages ship an affected version, including spatie/laravel-medialibrary.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spatie/laravel-medialibrary` | Packagist | All versions | 11.23.0 |
| `spatie/laravel-medialibrary` | Packagist | All versions | 11.23.0 |

## How do I fix CVE-2026-48557?

Upgrade spatie/laravel-medialibrary to 11.23.0 or later.

## Is CVE-2026-48557 being exploited?

There is no known exploitation of CVE-2026-48557 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48557 and fix it if it is affected.

What it is: CVE-2026-48557 is a high-severity vulnerability in spatie laravel-medialibrary, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48557 in the wild and no public exploit code.

Affected packages and fixed versions:
- spatie/laravel-medialibrary (Packagist): affected all versions; fixed in 11.23.0
- spatie/laravel-medialibrary (Packagist): affected all versions; fixed in 11.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48557/ (Markdown: https://insights.sbomify.com/CVE-2026-48557/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48557
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48557
- OSV: https://osv.dev/vulnerability/CVE-2026-48557

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48557/
Summaries are generated and may contain mistakes; the official description above is the record.
