CVE-2026-4858 Path traversal in integration action URL leading to arbitrary API execution via system admin’s auth token.
An authenticated user can exploit path traversal in integration URLs to execute arbitrary APIs using a system admin's auth token, leading to privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-4858?
CVE-2026-4858 is a high-severity path traversal vulnerability in Mattermost Mattermost Server, published on 21 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Mattermost versions 11.6.x <= 11.6.0, 11.5.x <= 11.5.3, 11.4.x <= 11.4.4, 10.11.x <= 10.11.14 fail to check integration URL for path traversal which allows an malicious authenticated user to call an arbitrary API via system admin Mattermost auth token using via path traversal in integration action URL.. Mattermost Advisory ID: MMSA-2026-00640
Weakness: CWE-22
Which versions are affected by CVE-2026-4858?
9 open source packages ship an affected version, including github.com/mattermost/mattermost-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.15 |
github.com/mattermost/mattermost-server Go | From 10.11.0 | 10.11.15 |
github.com/mattermost/mattermost-server Go | From 10.11.0+incompatible | 10.11.15+incompatible, 11.4.5+incompatible, 11.5.4+incompatible, 11.6.1+incompatible |
github.com/mattermost/mattermost-server Go | From 11.4.0 | 11.4.5 |
github.com/mattermost/mattermost-server Go | From 11.4.0 | 11.4.5 |
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.4 |
3 more packages
github.com/mattermost/mattermost-server Go | From 11.5.0 | 11.5.4 |
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.1 |
github.com/mattermost/mattermost-server Go | From 11.6.0 | 11.6.1 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2026-4858?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.11.15, 10.11.15+incompatible, 11.4.5+incompatible or 11.5.4+incompatible.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2026-4858 being exploited?
There is no known exploitation of CVE-2026-4858 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-c4r7-j7pp-r8mp, GO-2026-5311.