CVE-2026-48586 Denial of service in Apache Thrift

High 8.7 Published Updated

Attackers can cause denial of service in Apache Thrift applications by sending highly compressed data that exceeds decompression size limits.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-48586?

CVE-2026-48586 is a high-severity denial of service vulnerability in Apache Thrift, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift C++, Java, Python, Go, D, C/GLib bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Weakness: CWE-409

Which versions are affected by CVE-2026-48586?

1 open source package ship an affected version, including thrift. It affects 1 product.

PackageAffectedFixed in
thrift BitnamiAll versions0.24.0
Linux distribution packages (4)
jaeger Red Hat:hummingbird:1All versions0:2.20.0-0.4.hum1
loki3.7 Red Hat:hummingbird:1All versions0:3.7.4-0.1.hum1
loki3.7-canary Red Hat:hummingbird:1All versions0:3.7.4-0.1.hum1
loki3.7-logcli Red Hat:hummingbird:1All versions0:3.7.4-0.1.hum1

Products include Apache Thrift.

How do I fix CVE-2026-48586?

Upgrade thrift to 0.24.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-48586 being exploited?

There is no known exploitation of CVE-2026-48586 in the wild and no public exploit code.

Sources

Also known as AZL-94001, AZL-94166, AZL-94214, AZL-94238, AZL-94314, BIT-thrift-2026-48586 and 10 more.

Is CVE-2026-48586 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free