# CVE-2026-48588: Potential exposure of private data via cached Set-Cookie response

> Attackers can read private data from shared caches when Django caches responses varying on cookies, requiring specific middleware or decorator usage.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 7 Jul 2026
- **Also known as:** BIT-django-2026-48588, DEBIAN-CVE-2026-48588, ECHO-1b5a-ee63-2c52, GHSA-3h9f-r86x-qvjx, MINI-qqc8-2xq8-fcc7, MINI-vg46-58x3-5v5g, PYSEC-2026-2090, UBUNTU-CVE-2026-48588

## What is CVE-2026-48588?

CVE-2026-48588 is a low-severity vulnerability in Djangoproject Django, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in Django 6.0 before 6.0.7 and 5.2 before 5.2.16.
`UpdateCacheMiddleware` and the `cache_page()` decorator cache responses that vary on cookies when the incoming request carries unrelated cookies, which allows remote attackers to read private data from the shared cache.
Earlier, unsupported Django series (such as 5.0.x, 4.1.x, and 3.2.x) were not evaluated and may also be affected.
Django would like to thank Chris Whyland for reporting this issue.

Weakness: CWE-524 (Use of Cache Containing Sensitive Information)

## Which versions are affected by CVE-2026-48588?

6 open source packages ship an affected version, including django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | Bitnami | From 5.2.0 | 5.2.16, 6.0.7 |
| `django` | PyPI | All versions | 5.2.16 |
| `django` | PyPI | All versions | 5.2.16 |
| `django` | PyPI | From 5.2 | 5.2.16, 6.0.7 |
| `django` | PyPI | From 6.0.0 | 6.0.7 |
| `django` | PyPI | From 6.0.0 | 6.0.7 |

Products: Djangoproject Django.

## How do I fix CVE-2026-48588?

Upgrade django to a fixed version for your release line: 5.2.16 or 6.0.7.

## Is CVE-2026-48588 being exploited?

There is no known exploitation of CVE-2026-48588 in the wild and no public exploit code.

## Other vulnerabilities in Djangoproject Django

- [CVE-2026-4277](https://insights.sbomify.com/CVE-2026-4277/): Privilege abuse in GenericInlineModelAdmin (critical 9.8)
- [CVE-2024-53908](https://insights.sbomify.com/CVE-2024-53908/): Django SQL injection in HasKey(lhs, rhs) on Oracle (critical 9.8)
- [CVE-2024-42005](https://insights.sbomify.com/CVE-2024-42005/): Django SQL injection vulnerability (critical 9.8)
- [CVE-2023-31047](https://insights.sbomify.com/CVE-2023-31047/): Django bypasses validation when using one form field to upload multiple files (critical 9.8)
- [CVE-2022-34265](https://insights.sbomify.com/CVE-2022-34265/): Django `Trunc()` and `Extract()` database functions vulnerable to SQL Injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48588 and fix it if it is affected.

What it is: CVE-2026-48588 is a low-severity vulnerability in Djangoproject Django, published on 7 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-48588 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (Bitnami): affected from 5.2.0; fixed in 5.2.16, 6.0.7
- django (PyPI): affected all versions; fixed in 5.2.16
- django (PyPI): affected all versions; fixed in 5.2.16
- django (PyPI): affected from 5.2; fixed in 5.2.16, 6.0.7
- django (PyPI): affected from 6.0.0; fixed in 6.0.7
- django (PyPI): affected from 6.0.0; fixed in 6.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48588/ (Markdown: https://insights.sbomify.com/CVE-2026-48588/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48588
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48588
- OSV: https://osv.dev/vulnerability/CVE-2026-48588

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48588/
Summaries are generated and may contain mistakes; the official description above is the record.
