# CVE-2026-48594: Decompression bomb in Tesla.Middleware.DecompressResponse and Tesla.Middleware.Compression

> An attacker can cause a denial of service by sending a decompression bomb in an HTTP response, exhausting memory in applications using the Tesla library.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Jun 2026
- **Updated:** 24 Sep 2026
- **Also known as:** EEF-CVE-2026-48594, GHSA-mc85-72gr-vm9f

## What is CVE-2026-48594?

CVE-2026-48594 is a high-severity denial of service vulnerability in elixir-tesla tesla, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in elixir-tesla tesla allows a denial of service via decompression bomb in HTTP response bodies.

When Tesla.Middleware.DecompressResponse or Tesla.Middleware.Compression is included in a Tesla middleware pipeline, HTTP response bodies are decompressed eagerly with no size limit. The decompress_body/2 function in lib/tesla/middleware/compression.ex passes the entire response body to :zlib.gunzip/1 or :zlib.unzip/1 without any cap on the output size. Additionally, compression_algorithms/1 splits the content-encoding header on commas and decompress_body/2 recurses once per token, applying a decompression pass on each iteration. A server advertising content-encoding: gzip, gzip, gzip, gzip causes four recursive decompression passes, yielding exponential amplification: each gzip layer can expand its input roughly 1000x, so a payload of a few hundred bytes on the wire inflates to gigabytes of BEAM heap, exhausting memory and crashing or freezing the calling process.

This issue affects tesla: from 0.6.0 before 1.18.3.

Weakness: CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-48594?

3 open source packages ship an affected version, including tesla. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tesla` | Hex | From 0.6.0 | 1.18.3 |
| `tesla` | Hex | From 0.6.0 | 1.18.3 |
| `tesla` | Hex | From 0.6.0 | 1.18.3 |

Products: Elixir-Tesla Tesla.

## How do I fix CVE-2026-48594?

Upgrade tesla to 1.18.3 or later.

## Is CVE-2026-48594 being exploited?

There is no known exploitation of CVE-2026-48594 in the wild and no public exploit code.

## Other vulnerabilities in elixir-tesla tesla

- [CVE-2026-48595](https://insights.sbomify.com/CVE-2026-48595/): Authorization header leaks to third-party origin on cross-origin redirect in Tesla.Middleware.FollowRedirects (high 8.2)
- [CVE-2026-48597](https://insights.sbomify.com/CVE-2026-48597/): Atom table exhaustion via untrusted URL scheme in Tesla.Adapter.Mint (high 8.2)
- [CVE-2026-48596](https://insights.sbomify.com/CVE-2026-48596/): CRLF injection in Tesla.Multipart.add_content_type_param/2 allows HTTP header injection (low 2.1)
- [CVE-2026-48598](https://insights.sbomify.com/CVE-2026-48598/): CRLF injection in Tesla.Multipart disposition parameters allows multipart part header injection (low 2.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48594 and fix it if it is affected.

What it is: CVE-2026-48594 is a high-severity denial of service vulnerability in elixir-tesla tesla, published on 2 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48594 in the wild and no public exploit code.

Affected packages and fixed versions:
- tesla (Hex): affected from 0.6.0; fixed in 1.18.3
- tesla (Hex): affected from 0.6.0; fixed in 1.18.3
- tesla (Hex): affected from 0.6.0; fixed in 1.18.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48594/ (Markdown: https://insights.sbomify.com/CVE-2026-48594/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48594
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48594
- OSV: https://osv.dev/vulnerability/CVE-2026-48594

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48594/
Summaries are generated and may contain mistakes; the official description above is the record.
