# CVE-2026-48681: OpenStack Ironic allows file overwrite via directory traversal during deployment with a crafted ISO image

> Attackers can overwrite files via directory traversal using a crafted ISO image during deployment in OpenStack Ironic.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2026
- **Updated:** 4 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-48681, GHSA-9v62-qx4c-44x5, PYSEC-2026-3470, UBUNTU-CVE-2026-48681

## What is CVE-2026-48681?

CVE-2026-48681 is a medium-severity path traversal vulnerability in OpenStack Ironic, published on 4 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

OpenStack Ironic through before 35.0.2 allows file overwrite via directory traversal during deployment with a crafted ISO image.

Weakness: CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2026-48681?

9 open source packages ship an affected version, including ironic. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ironic` | PyPI | From 17.0.0 | 26.1.7, 29.0.6, 32.0.2, 35.0.2 |
| `ironic` | PyPI | From 17.0.0 | 26.1.7 |
| `ironic` | PyPI | From 17.0.0 | 26.1.7 |
| `ironic` | PyPI | From 27.0.0 | 29.0.6 |
| `ironic` | PyPI | From 27.0.0 | 29.0.6 |
| `ironic` | PyPI | From 30.0.0 | 32.0.2 |
| `ironic` | PyPI | From 30.0.0 | 32.0.2 |
| `ironic` | PyPI | From 33.0.0 | 35.0.2 |
| `ironic` | PyPI | From 33.0.0 | 35.0.2 |

Products: Openstack Ironic.

## How do I fix CVE-2026-48681?

Upgrade ironic to a fixed version for your release line: 26.1.7, 29.0.6, 32.0.2 or 35.0.2.

## Is CVE-2026-48681 being exploited?

There is no known exploitation of CVE-2026-48681 in the wild and no public exploit code.

## Other vulnerabilities in OpenStack Ironic

- [CVE-2026-42997](https://insights.sbomify.com/CVE-2026-42997/): OpenStack Ironic has an Incorrect Resource Transfer Between Spheres (high 7.7)
- [CVE-2026-42510](https://insights.sbomify.com/CVE-2026-42510/): OpenStack Ironic is Vulnerable to Inclusion of Functionality from Untrusted Control Sphere (medium 6.6)
- [CVE-2015-7514](https://insights.sbomify.com/CVE-2015-7514/): Information disclosure in n/a (medium 6.5)
- [CVE-2026-46447](https://insights.sbomify.com/CVE-2026-46447/): OpenStack Ironic allows Boot Script Injection (medium 5.8)
- [CVE-2026-50589](https://insights.sbomify.com/CVE-2026-50589/): OpenStack Ironic: Crafted JSON String to Certain Endpoints on the API or JSON-RPC Service May Result in Service Crash (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48681 and fix it if it is affected.

What it is: CVE-2026-48681 is a medium-severity path traversal vulnerability in OpenStack Ironic, published on 4 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48681 in the wild and no public exploit code.

Affected packages and fixed versions:
- ironic (PyPI): affected from 17.0.0; fixed in 26.1.7, 29.0.6, 32.0.2, 35.0.2
- ironic (PyPI): affected from 17.0.0; fixed in 26.1.7
- ironic (PyPI): affected from 17.0.0; fixed in 26.1.7
- ironic (PyPI): affected from 27.0.0; fixed in 29.0.6
- ironic (PyPI): affected from 27.0.0; fixed in 29.0.6
- ironic (PyPI): affected from 30.0.0; fixed in 32.0.2
- ironic (PyPI): affected from 30.0.0; fixed in 32.0.2
- ironic (PyPI): affected from 33.0.0; fixed in 35.0.2
- ironic (PyPI): affected from 33.0.0; fixed in 35.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48681/ (Markdown: https://insights.sbomify.com/CVE-2026-48681/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48681
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48681
- OSV: https://osv.dev/vulnerability/CVE-2026-48681

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48681/
Summaries are generated and may contain mistakes; the official description above is the record.
