# CVE-2026-48712: protobufjs: Denial of service through unbounded Any expansion during JSON conversion

> Attackers can cause denial of service in applications using protobufjs by sending crafted payloads that exhaust the call stack during JSON conversion.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** CLEANSTART-2026-OS65613, CLEANSTART-2026-YP30381, ECHO-e567-f725-0f5b, GHSA-wcpc-wj8m-hjx6, MINI-2pxx-9wrc-r8px, MINI-3hmx-rq3w-wr3h, MINI-3ph4-hv4r-4r5m, MINI-4gqf-rq6f-vj7w, MINI-4qpw-8763-44j4, MINI-6q2m-3wvg-8j23, MINI-6r63-pm6x-c45h, MINI-8f67-g2jw-2p8j, MINI-8j5g-ccqj-vm95, MINI-9m34-qqxr-495h, MINI-9m4h-v755-mv8m, MINI-f877-jgw3-jv2f, MINI-fg86-pvgp-mr7g, MINI-gwrh-938v-fvxf, MINI-m8r8-v3rr-rc8r, MINI-pqmj-w5v3-rx57, MINI-wg6v-2mrh-hqrc, MINI-x3mq-c9cg-qv2j, MINI-x6r5-x3fj-q4ww, ROOT-APP-NPM-CVE-2026-48712

## What is CVE-2026-48712?

CVE-2026-48712 is a high-severity denial of service vulnerability in protobufjs protobuf.js, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

protobufjs compiles protobuf definitions into JavaScript (JS) functions. Prior to 7.6.1 and 8.4.1, protobufjs could recurse without a depth limit while converting decoded messages to plain objects or JSON. This affected generated toObject() conversion and the custom google.protobuf.Any JSON conversion path. A crafted protobuf binary payload containing deeply nested Any values could cause the JavaScript call stack to be exhausted during conversion to JSON. This vulnerability is fixed in 7.6.1 and 8.4.1.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-48712?

4 open source packages ship an affected version, including protobufjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `protobufjs` | npm | All versions | 7.6.1 |
| `protobufjs` | npm | All versions | 7.6.1 |
| `protobufjs` | npm | From 8.0.0 | 8.4.1 |
| `protobufjs` | npm | From 8.0.0 | 8.4.1 |

Products: Protobufjs Project Protobufjs.

## How do I fix CVE-2026-48712?

Upgrade protobufjs to a fixed version for your release line: 7.6.1 or 8.4.1.

## Is CVE-2026-48712 being exploited?

There is no known exploitation of CVE-2026-48712 in the wild and no public exploit code.

## Other vulnerabilities in protobufjs protobuf.js

- [CVE-2023-36665](https://insights.sbomify.com/CVE-2023-36665/): protobufjs Prototype Pollution vulnerability (critical 9.8)
- [CVE-2026-41242](https://insights.sbomify.com/CVE-2026-41242/): protobufjs has an arbitrary code execution issue (critical 9.4)
- [CVE-2022-25878](https://insights.sbomify.com/CVE-2022-25878/): Prototype Pollution (high 8.2)
- [CVE-2026-44291](https://insights.sbomify.com/CVE-2026-44291/): protobufjs: Code generation gadget after prototype pollution (high 8.1)
- [CVE-2026-44293](https://insights.sbomify.com/CVE-2026-44293/): protobufjs: Code injection through bytes field defaults in generated toObject code (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48712 and fix it if it is affected.

What it is: CVE-2026-48712 is a high-severity denial of service vulnerability in protobufjs protobuf.js, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48712 in the wild and no public exploit code.

Affected packages and fixed versions:
- protobufjs (npm): affected all versions; fixed in 7.6.1
- protobufjs (npm): affected all versions; fixed in 7.6.1
- protobufjs (npm): affected from 8.0.0; fixed in 8.4.1
- protobufjs (npm): affected from 8.0.0; fixed in 8.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48712/ (Markdown: https://insights.sbomify.com/CVE-2026-48712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48712
- OSV: https://osv.dev/vulnerability/CVE-2026-48712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48712/
Summaries are generated and may contain mistakes; the official description above is the record.
