{"answers":{"affected":"2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-oauth2.","exploited":"There is no known exploitation of CVE-2026-48717 in the wild and no public exploit code.","fix":"Upgrade org.openidentityplatform.openam:openam-oauth2 to 16.1.1 or later.","what":"CVE-2026-48717 is a critical authentication bypass vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-48717 and fix it if it is affected.\n\nWhat it is: CVE-2026-48717 is a critical authentication bypass vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-48717 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.openidentityplatform.openam:openam-oauth2 (Maven): affected all versions; fixed in 16.1.1\n- org.openidentityplatform.openam:openam-oauth2 (Maven): affected all versions; fixed in 16.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-48717/ (Markdown: https://insights.sbomify.com/CVE-2026-48717/index.md)","id":"CVE-2026-48717","markdown":"https://insights.sbomify.com/CVE-2026-48717/index.md","name":"CVE-2026-48717","record":{"aliases":["GHSA-4v2w-2wqp-mc85","UBUNTU-CVE-2026-48717"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenAM access management","requires_auth":"none","summary":"Attackers can bypass PKCE protection to redeem intercepted authorization codes, potentially taking over accounts in OpenAM deployments.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-285","name":"Improper Authorization"}],"description":"Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, AuthorizationCodeGrantTypeHandler requires a code_verifier only when the realm-wide codeVerifierEnforced setting is enabled, even when an authorization code stores a code_challenge. Because that setting is disabled by default, an attacker who intercepts a PKCE-protected authorization code can omit code_verifier and redeem the code, while an explicitly incorrect verifier is rejected. Public clients are directly affected, and confidential-client exploitation additionally requires client authentication material or another redemption context. This issue is fixed in version 16.1.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenAM OAuth Authorization Bypass via PKCE Challenge","id":"CVE-2026-48717","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Warp branch selector command injection via Git branch names","id":"CVE-2026-48719"},"packages":[{"ecosystem":"Maven","fixed":["16.1.1"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-oauth2","purl":null,"source":"GHSA-4v2w-2wqp-mc85"},{"ecosystem":"Maven","fixed":["16.1.1"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-oauth2","purl":"pkg:maven/org.openidentityplatform.openam/openam-oauth2","source":"GHSA-4v2w-2wqp-mc85"}],"prev":{"headline":"nanobot: Path traversal via unsanitized WhatsApp document fileName enables arbitrary file write","id":"CVE-2026-48716"},"products":["OpenAM"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-15","vendors":["OpenIdentityPlatform"]},"summary":"Attackers can bypass PKCE protection to redeem intercepted authorization codes, potentially taking over accounts in OpenAM deployments.","url":"https://insights.sbomify.com/CVE-2026-48717/"}