# CVE-2026-48723: Command injection in browserstack-cypress-cli

> Attackers can execute arbitrary OS commands by injecting shell metacharacters into the cypress_config_file parameter in BrowserStack Cypress CLI.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Jun 2026
- **Updated:** 16 Jun 2026
- **Also known as:** GHSA-fh4c-mffm-8xhf

## What is CVE-2026-48723?

CVE-2026-48723 is a high-severity command injection vulnerability in browserstack-cypress-cli, published on 15 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

The browserstack-cypress-cli is BrowserStack's CLI which allows users to run Cypress tests on BrowserStack. Versions prior to 1.36.4 are vulnerable to OS command injection via the cypress_config_file configuration parameter. In readCypressConfigUtil.js, the loadJsFile() function constructs a shell command by interpolating the user-controlled cypress_config_filepath value into a template literal, then executes it via child_process.execSync(). Shell metacharacters in the config path (specifically " and ;) allow breaking out of the quoted argument and injecting arbitrary commands. This issue has been fixed in version 1.36.6.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-48723?


## How do I fix CVE-2026-48723?

No fix has been published for CVE-2026-48723 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-48723 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48723 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48723 and fix it if it is affected.

What it is: CVE-2026-48723 is a high-severity command injection vulnerability in browserstack-cypress-cli, published on 15 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48723 exists.

Affected product: browserstack-cypress-cli. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48723/ (Markdown: https://insights.sbomify.com/CVE-2026-48723/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48723
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48723
- OSV: https://osv.dev/vulnerability/CVE-2026-48723

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48723/
Summaries are generated and may contain mistakes; the official description above is the record.
