# CVE-2026-48741: libIEC61850: Remote NULL dereference in MMS Read alternate-access sub-array path leads to server-side DoS

> Remote attackers can crash IEC 61850 servers by sending malformed MMS Read requests, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-8mfr-hq64-9w33

## What is CVE-2026-48741?

CVE-2026-48741 is a high-severity vulnerability in mz-automation libiec61850, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

libIEC61850 is an open-source implementation of IEC 61850 client and server protocols including MMS, GOOSE, Sampled Values, and R-Session. Prior to 1.6.2, alternateArrayAccess in src/mms/iso_mms/server/mms_read_service.c does not validate an alternate-access sub-array range when numberOfElements is greater than zero. An out-of-range MmsValue_getElement call returns NULL, and the sub-array branch passes that value to MmsValue_isDeletable, causing a NULL pointer dereference. A remote MMS Read request can therefore crash servers whose data models contain arrays, while the single-element error path handles the same invalid index safely. This issue is fixed in version 1.6.2.

Weakness: CWE-476 (NULL Pointer Dereference), CWE-252 (Unchecked Return Value), CWE-754 (Improper Check for Unusual or Exceptional Conditions), CWE-129 (Improper Validation of Array Index)

## Which versions are affected by CVE-2026-48741?


## How do I fix CVE-2026-48741?

No fix has been published for CVE-2026-48741 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-48741 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48741 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48741 and fix it if it is affected.

What it is: CVE-2026-48741 is a high-severity vulnerability in mz-automation libiec61850, published on 16 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48741 exists.

Affected product: mz-automation libiec61850. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48741/ (Markdown: https://insights.sbomify.com/CVE-2026-48741/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48741
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48741
- OSV: https://osv.dev/vulnerability/CVE-2026-48741

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48741/
Summaries are generated and may contain mistakes; the official description above is the record.
