CVE-2026-48743 Envoy: HTTP/3 to HTTP/1 request smuggling via headers-only request with nonzero Content-Length
Attackers can bypass security controls and access restricted resources by exploiting HTTP request smuggling between HTTP/3 and HTTP/1 protocols in Envoy.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-48743?
CVE-2026-48743 is a high-severity vulnerability in Envoyproxy Envoy, published on 26 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Envoy is an open source edge and service proxy designed for cloud-native applications. Prior to 1.35.11, 1.36.7, 1.37.3, and 1.38.1, Envoy can translate a downstream HTTP/3 request that is complete at the transport layer (HEADERS with FIN / headers-only close) but still carries a nonzero Content-Length into a complete upstream HTTP/1 request with unresolved body debt. In an HTTP/1 upstream deployment where the origin replies before reading the declared body and keeps the connection reusable, the beginning of the next Envoy-generated upstream request can be consumed as the first request's body. The remaining bytes are then parsed by the origin as a new HTTP/1 request. This was reproduced as a route-bypass/desync: direct /pwn was denied by Envoy, but the second downstream H3 stream received the response for backend-parsed GET /pwn HTTP/1.1. This vulnerability is fixed in 1.35.11, 1.36.7, 1.37.3, and 1.38.1.
Weakness: CWE-444
Which versions are affected by CVE-2026-48743?
1 open source package ship an affected version, including envoy. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
envoy Bitnami | From 1.35.0 | 1.35.11, 1.36.7, 1.37.3, 1.38.1 |
Products include Envoyproxy Envoy.
How do I fix CVE-2026-48743?
Upgrade envoy to a fixed version for your release line: 1.35.11, 1.36.7, 1.37.3 or 1.38.1.
Is CVE-2026-48743 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48743 exists.
Other vulnerabilities in Envoyproxy Envoy
Sources
Also known as BIT-envoy-2026-48743, GHSA-8phg-2h2q-jgxf.