CVE-2026-48746 vLLM: OpenAI auth bypass

Critical 9.1 Published Updated

Attackers can bypass OpenAI API authentication in vLLM to access the API without providing the configured API key.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-48746?

CVE-2026-48746 is a critical authentication bypass vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

vLLM is an inference and serving engine for large language models (LLMs). From 0.3.0 until 0.22.0, a vulnerability in ASGI web servers and starlette's trust on those web servers enables an authentication bypass of the OpenAI API AuthenticationMiddleware. It allows to use the API without providing the configured VLLM_API_KEY or --api-key. This vulnerability is fixed in 0.22.0.

Weakness: CWE-501, CWE-444

Which versions are affected by CVE-2026-48746?

3 open source packages ship an affected version, including vllm. It affects 1 product.

PackageAffectedFixed in
vllm PyPIFrom 0.3.00.22.0
vllm PyPIFrom 0.3.00.22.0
vllm PyPIFrom 0.3.00.22.0

Products include Vllm Vllm.

How do I fix CVE-2026-48746?

Upgrade vllm to 0.22.0 or later.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-48746 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48746 exists.

All Vllm Vllm vulnerabilities

Sources

Also known as GHSA-94f4-hr76-p5j6, MINI-357x-mh56-h27j, MINI-9g3f-jm52-5vcc, MINI-fvcq-7xm6-xvx9, PYSEC-2026-226.

Is CVE-2026-48746 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free