{"answers":{"affected":"3 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48746 exists.","fix":"Upgrade vllm to 0.22.0 or later.","what":"CVE-2026-48746 is a critical authentication bypass vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-48746 and fix it if it is affected.\n\nWhat it is: CVE-2026-48746 is a critical authentication bypass vulnerability in Vllm Vllm, published on 22 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48746 exists.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.3.0; fixed in 0.22.0\n- vllm (PyPI): affected from 0.3.0; fixed in 0.22.0\n- vllm (PyPI): affected from 0.3.0; fixed in 0.22.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-48746/ (Markdown: https://insights.sbomify.com/CVE-2026-48746/index.md)","id":"CVE-2026-48746","markdown":"https://insights.sbomify.com/CVE-2026-48746/index.md","name":"CVE-2026-48746","record":{"aliases":["GHSA-94f4-hr76-p5j6","MINI-357x-mh56-h27j","MINI-9g3f-jm52-5vcc","MINI-fvcq-7xm6-xvx9","PYSEC-2026-226"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM inference engine","requires_auth":"none","summary":"Attackers can bypass OpenAI API authentication in vLLM to access the API without providing the configured API key.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-501","name":"Trust Boundary Violation"},{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"vLLM is an inference and serving engine for large language models (LLMs). From 0.3.0 until 0.22.0, a vulnerability in ASGI web servers and starlette's trust on those web servers enables an authentication bypass of the OpenAI API AuthenticationMiddleware. It allows to use the API without providing the configured VLLM_API_KEY or --api-key. This vulnerability is fixed in 0.22.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"auth_bypass","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Symfony: Mailomat Mailer Webhook Parser Reads the HMAC Algorithm from the Request: Signature Algorithm Downgrade","id":"CVE-2026-48747"},"packages":[{"ecosystem":"PyPI","fixed":["0.22.0"],"introduced":["0.3.0"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-94f4-hr76-p5j6"},{"ecosystem":"PyPI","fixed":["0.22.0"],"introduced":["0.3.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-94f4-hr76-p5j6"},{"ecosystem":"PyPI","fixed":["0.22.0"],"introduced":["0.3.0"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2026-226"}],"prev":{"headline":"Traccar Client: silent configuration hijack via unverified deep link redirects all GPS telemetry","id":"CVE-2026-48745"},"products":["vllm"],"published":"2026-06-22","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-16","vendors":["vllm-project"]},"summary":"Attackers can bypass OpenAI API authentication in vLLM to access the API without providing the configured API key.","url":"https://insights.sbomify.com/CVE-2026-48746/"}