# CVE-2026-48748: Netty HTTP/3 QPACK Blocked Streams Memory Exhaustion

> Attackers can exhaust memory by creating infinite blocked streams in Netty HTTP/3, causing denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 4 Aug 2026
- **Also known as:** CLEANSTART-2026-MC53420, DEBIAN-CVE-2026-48748, ECHO-6f9b-1ba3-a572, GHSA-4grm-h2qv-h6w6, MINI-23q5-wq24-fgv4, MINI-3qqx-wcm8-gfqf, MINI-4r66-c3wm-4c9q, MINI-5xw9-p756-4g38, MINI-952x-hw8q-2xvm, MINI-fvfj-8v6m-5934, MINI-mh3r-46rm-7736, MINI-xhv5-mwhq-4wcr, UBUNTU-CVE-2026-48748

## What is CVE-2026-48748?

CVE-2026-48748 is a high-severity denial of service vulnerability in Netty Netty, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is a network application framework for development of protocol servers and clients. Starting in version 4.2.0.Final and prior to version 4.2.15.Final, a memory exhaustion vulnerability in the Netty HTTP/3 codec allows the creation of an infinite number of blocked streams, which can cause OOM error. Version 4.2.15.Final patches the issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-48748?

2 open source packages ship an affected version, including io.netty:netty-codec-http3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-http3` | Maven | From 4.2.0.Final | 4.2.15.Final |
| `io.netty:netty-codec-http3` | Maven | From 4.2.0.Final | 4.2.15.Final |

Products: Netty Netty.

## How do I fix CVE-2026-48748?

Upgrade io.netty:netty-codec-http3 to 4.2.15.Final or later.

## Is CVE-2026-48748 being exploited?

There is no known exploitation of CVE-2026-48748 in the wild and no public exploit code.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48748 and fix it if it is affected.

What it is: CVE-2026-48748 is a high-severity denial of service vulnerability in Netty Netty, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48748 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-codec-http3 (Maven): affected from 4.2.0.Final; fixed in 4.2.15.Final
- io.netty:netty-codec-http3 (Maven): affected from 4.2.0.Final; fixed in 4.2.15.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48748/ (Markdown: https://insights.sbomify.com/CVE-2026-48748/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48748
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48748
- OSV: https://osv.dev/vulnerability/CVE-2026-48748

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48748/
Summaries are generated and may contain mistakes; the official description above is the record.
