# CVE-2026-48755: Incus has an argument injection in backup compression algorithm leading to AFW and ACE

> Attackers can inject arguments into backup commands to write arbitrary files and execute code on the host.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** DEBIAN-CVE-2026-48755, GHSA-v6mj-8pf4-hhw4, GO-2026-5808, UBUNTU-CVE-2026-48755

## What is CVE-2026-48755?

CVE-2026-48755 is a critical command injection vulnerability in lxc incus, published on 21 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incus is a system container and virtual machine manager. Prior to version 7.1.0, improper validation of user-provided backup compression algorithm leads to argument injection in the constructed command line. This leads to an arbitrary file write on the host, possibly leading to arbitrary command execution. Version 7.1.0 patches the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-48755?

5 open source packages ship an affected version, including github.com/lxc/incus/v7/cmd/incusd, github.com/lxc/incus and github.com/lxc/incus/v6.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/incus/v7/cmd/incusd` | Go | All versions | 7.2.0 |
| `github.com/lxc/incus/v7/cmd/incusd` | Go | All versions | 7.2.0 |
| `github.com/lxc/incus` | Go | All versions | None |
| `github.com/lxc/incus/v6` | Go | All versions | None |
| `github.com/lxc/incus/v7` | Go | All versions | 7.2.0 |

## How do I fix CVE-2026-48755?

Upgrade github.com/lxc/incus/v7/cmd/incusd to 7.2.0 or later.

## Is CVE-2026-48755 being exploited?

There is no known exploitation of CVE-2026-48755 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48755 and fix it if it is affected.

What it is: CVE-2026-48755 is a critical command injection vulnerability in lxc incus, published on 21 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48755 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/lxc/incus/v7/cmd/incusd (Go): affected all versions; fixed in 7.2.0
- github.com/lxc/incus/v7/cmd/incusd (Go): affected all versions; fixed in 7.2.0
- github.com/lxc/incus (Go): affected all versions; no fix listed
- github.com/lxc/incus/v6 (Go): affected all versions; no fix listed
- github.com/lxc/incus/v7 (Go): affected all versions; fixed in 7.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48755/ (Markdown: https://insights.sbomify.com/CVE-2026-48755/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48755
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48755
- OSV: https://osv.dev/vulnerability/CVE-2026-48755

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48755/
Summaries are generated and may contain mistakes; the official description above is the record.
