# CVE-2026-48758: sigstore-js: DSSE payloadType type-binding failure

> Attackers can mutate payload types after signing without invalidating signatures, breaking DSSE type-binding guarantees in sigstore-js.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLEANSTART-2026-BS35481, CLEANSTART-2026-FS67325, CLSA-2026-1790597352, CLSA-2026-1792603628, CLSA-2026-1793143332, GHSA-jfc7-64v2-mr8c, MINI-2whv-4pg9-mw2p, MINI-4jxj-935j-329c, MINI-5p8x-5h8x-ghgh, MINI-5wp8-c9f4-958h, MINI-mxqg-qgvj-79qp, MINI-p84j-66f7-j9hq, MINI-rx25-x2r2-rrxj, ROOT-APP-NPM-CVE-2026-48758

## What is CVE-2026-48758?

CVE-2026-48758 is a medium-severity vulnerability in sigstore-js, published on 14 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

sigstore-js provides JavaScript libraries for interacting with Sigstore services. Prior to 3.2.1, the preAuthEncoding function in @sigstore/core uses Node.js ascii encoding when converting the PAE string to bytes, allowing payloadType to be mutated after signing without invalidating the signature and breaking the type-binding guarantee that DSSE is designed to provide. This issue is fixed in version 3.2.1.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-48758?

2 open source packages ship an affected version, including @sigstore/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sigstore/core` | npm | All versions | 3.2.1 |
| `@sigstore/core` | npm | All versions | 3.2.1 |

## How do I fix CVE-2026-48758?

Upgrade @sigstore/core to 3.2.1 or later.

## Is CVE-2026-48758 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48758 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48758 and fix it if it is affected.

What it is: CVE-2026-48758 is a medium-severity vulnerability in sigstore-js, published on 14 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48758 exists.

Affected packages and fixed versions:
- @sigstore/core (npm): affected all versions; fixed in 3.2.1
- @sigstore/core (npm): affected all versions; fixed in 3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48758/ (Markdown: https://insights.sbomify.com/CVE-2026-48758/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48758
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48758
- OSV: https://osv.dev/vulnerability/CVE-2026-48758

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48758/
Summaries are generated and may contain mistakes; the official description above is the record.
