CVE-2026-48773 ProxySQL pre-auth heap overflow in MySQL and PostgreSQL first-packet handling
Remote unauthenticated attackers can trigger heap memory corruption in ProxySQL via oversized first packets, potentially leading to code execution or service disruption.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-48773?
CVE-2026-48773 is a critical memory corruption vulnerability in sysown proxysql, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
ProxySQL is a proxy for MySQL and its forks, as well as PostgreSQL. Versions 2.0.18 through 3.0.8 have a pre-authentication heap memory corruption vulnerability in the MySQL and PostgreSQL protocol first-read paths. A remote unauthenticated client can declare an oversized first packet length, and ProxySQL passes that attacker-controlled length directly to `recv()` while writing into a fixed 32 KB input queue. Version 3.0.9 patches the issue.
Weakness: CWE-787
Which versions are affected by CVE-2026-48773?
1 open source package ship an affected version, including proxysql. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
proxysql Bitnami | From 2.0.18 | 3.0.9 |
Products include Proxysql Proxysql.
How do I fix CVE-2026-48773?
Upgrade proxysql to 3.0.9 or later.
Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.
Is CVE-2026-48773 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48773 exists.
Other vulnerabilities in sysown proxysql
Sources
Also known as BIT-proxysql-2026-48773, GHSA-58ww-865x-grpr.