# CVE-2026-48773: ProxySQL pre-auth heap overflow in MySQL and PostgreSQL first-packet handling

> Remote unauthenticated attackers can trigger heap memory corruption in ProxySQL via oversized first packets, potentially leading to code execution or service disruption.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** BIT-proxysql-2026-48773, GHSA-58ww-865x-grpr

## What is CVE-2026-48773?

CVE-2026-48773 is a critical memory corruption vulnerability in sysown proxysql, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ProxySQL is a proxy for MySQL and its forks, as well as PostgreSQL. Versions 2.0.18 through 3.0.8 have a pre-authentication heap memory corruption vulnerability in the MySQL and PostgreSQL protocol first-read paths. A remote unauthenticated client can declare an oversized first packet length, and ProxySQL passes that attacker-controlled length directly to `recv()` while writing into a fixed 32 KB input queue. Version 3.0.9 patches the issue.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2026-48773?

1 open source package ship an affected version, including proxysql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `proxysql` | Bitnami | From 2.0.18 | 3.0.9 |

Products: Proxysql Proxysql.

## How do I fix CVE-2026-48773?

Upgrade proxysql to 3.0.9 or later.

## Is CVE-2026-48773 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48773 exists.

## Other vulnerabilities in sysown proxysql

- [CVE-2026-48772](https://insights.sbomify.com/CVE-2026-48772/): ProxySQL: PROXY-Protocol-v1 UNKNOWN parses spoofed source IP, bypassing mysql_query_rules.client_addr ACL (critical 10.0)
- [CVE-2026-48774](https://insights.sbomify.com/CVE-2026-48774/): ProxySQL MCP run_sql_readonly executes side-effecting MySQL multi-statements despite read-only contract (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48773 and fix it if it is affected.

What it is: CVE-2026-48773 is a critical memory corruption vulnerability in sysown proxysql, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48773 exists.

Affected packages and fixed versions:
- proxysql (Bitnami): affected from 2.0.18; fixed in 3.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48773/ (Markdown: https://insights.sbomify.com/CVE-2026-48773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48773
- OSV: https://osv.dev/vulnerability/CVE-2026-48773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48773/
Summaries are generated and may contain mistakes; the official description above is the record.
