# CVE-2026-48781: Postiz has cross-tenant SUPERADMIN takeover via Skool-provider JWT forgery

> Authenticated users can forge JWTs to gain SUPERADMIN access and impersonate other organizations in Postiz.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 16 Jun 2026
- **Updated:** 18 Jun 2026
- **Also known as:** GHSA-j77w-h625-56q2

## What is CVE-2026-48781?

CVE-2026-48781 is a critical authentication bypass vulnerability in gitroomhq postiz-app, published on 16 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Postiz is an AI social media scheduling tool. In versions prior to 2.21.8, the Skool integration callback signed an attacker-controlled JSON blob into a session-shape JWT using the application's JWT_SECRET, and the auth middleware trusted every claim in that JWT without re-resolving the user from the database. Any authenticated Postiz user could forge a SUPERADMIN session and impersonate arbitrary organizations. This allowed Full Access to the following: all parts of Postiz, including users registered to the specific instance and the ability to post in the name of the victim's social media channels added to that Postiz instance. This issue has been fixed in version 2.21.8.

Weakness: CWE-863 (Incorrect Authorization), CWE-345 (Insufficient Verification of Data Authenticity), CWE-302 (Authentication Bypass by Assumed-Immutable Data)

## Which versions are affected by CVE-2026-48781?


## How do I fix CVE-2026-48781?

No fix has been published for CVE-2026-48781 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-48781 being exploited?

There is no known exploitation of CVE-2026-48781 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48781 and fix it if it is affected.

What it is: CVE-2026-48781 is a critical authentication bypass vulnerability in gitroomhq postiz-app, published on 16 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48781 in the wild and no public exploit code.

Affected product: gitroomhq postiz-app. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48781/ (Markdown: https://insights.sbomify.com/CVE-2026-48781/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48781
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48781
- OSV: https://osv.dev/vulnerability/CVE-2026-48781

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48781/
Summaries are generated and may contain mistakes; the official description above is the record.
