CVE-2026-48784 Symfony: UrlGenerator Dot-Segment Encoding Skips Every Other Chained `../` or `./` → Generated URL Collapses Off-Route Under RFC 3986 Normalization
Attackers can craft route parameters to generate URLs that redirect to unintended paths due to flawed dot-segment encoding in Symfony's UrlGenerator.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-48784?
CVE-2026-48784 is a medium-severity vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 5.4.53, 6.4.41, 7.4.13, and 8.0.13, UrlGenerator::doGenerate() used strtr() dot-segment encoding that skipped every other chained ../ or ./ segment, allowing attacker-controlled route parameters to generate URLs that collapse to a different path under RFC 3986 normalization. This issue is fixed in versions 5.4.53, 6.4.41, 7.4.13, and 8.0.13.
Which versions are affected by CVE-2026-48784?
16 open source packages ship an affected version, including symfony/routing and symfony/symfony. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/routing Packagist | All versions | 5.4.53 |
symfony/routing Packagist | All versions | 5.4.53 |
symfony/routing Packagist | From 6.0.0 | 6.4.41 |
symfony/routing Packagist | From 6.0.0 | 6.4.41 |
symfony/routing Packagist | From 7.0.0 | 7.4.13 |
symfony/routing Packagist | From 7.0.0 | 7.4.13 |
10 more packages
symfony/routing Packagist | From 8.0.0 | 8.0.13 |
symfony/routing Packagist | From 8.0.0 | 8.0.13 |
symfony/symfony Packagist | All versions | 5.4.53 |
symfony/symfony Packagist | All versions | 5.4.53 |
symfony/symfony Packagist | From 6.0.0 | 6.4.41 |
symfony/symfony Packagist | From 6.0.0 | 6.4.41 |
symfony/symfony Packagist | From 7.0.0 | 7.4.13 |
symfony/symfony Packagist | From 7.0.0 | 7.4.13 |
symfony/symfony Packagist | From 8.0.0 | 8.0.13 |
symfony/symfony Packagist | From 8.0.0 | 8.0.13 |
Products include Sensiolabs Symfony.
How do I fix CVE-2026-48784?
Upgrade symfony/routing to a fixed version for your release line: 5.4.53, 6.4.41, 7.4.13 or 8.0.13.
Is CVE-2026-48784 being exploited?
There is no known exploitation of CVE-2026-48784 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as DEBIAN-CVE-2026-48784, GHSA-h5x3-xfc9-m39h, UBUNTU-CVE-2026-48784.