CVE-2026-48794 Authelia has an Edge Case Access Control Rule Mismatch
Attackers can bypass access control rules in Authelia by exploiting domain canonicalization flaws in specific forwarded authorization configurations.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-48794?
CVE-2026-48794 is a low-severity authentication bypass vulnerability in authelia, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Authelia is an open-source authentication and authorization server providing two-factor authentication and single sign-on (SSO) for applications via a web portal. In versions 4.36.0 through 4.39.19, due to lack of canonicalization of domains in very specific edge cases, an access control rule may be skipped when it should match a request. The specific conditions that could lead to a security issue for vulnerability are: 1. The specific target resource of the attack must be using the forwarded authorization integration; 2. The requested domain must have two additional segments compared to a session domain i.e. `a.b.example.com` is requested, but the session domain is `example.com`; 3. There access control rules must specify two separate rules which both contain inexact domain matches such as `*.b.example.com` and `*.example.com` i.e. wildcards, username matches, group matches; 4. The rules must be in order of most specific domain to least specific domain; 5. The second rule must be more permissive than the first rule; 6. The attacker must specifically request a URL for the more specific domain, with the second part containing one or more capitalized letters i.e. `https://a.B.example.com` and no other segment with capitalized letters; 7. The integration used must not be the Envoy ExtAuthz integration; and 8. The proxy must not canonicalize the requested host name in the relevant header before sending it to the relevant authorization endpoint. The kind of configuration used to produce this issue and result in a `bypass` rule being matched has long been highly discouraged. Essentially hosts which should be bypassed entirely should not be secured by having the proxy check them with the authorization handlers. Upgrade to 4.39.20 to receive a patch.
Which versions are affected by CVE-2026-48794?
4 open source packages ship an affected version, including github.com/authelia/authelia/v4 and github.com/authelia/authelia.
| Package | Affected | Fixed in |
|---|---|---|
github.com/authelia/authelia/v4 Go | From 4.36.0 | 4.39.20 |
github.com/authelia/authelia/v4 Go | From 4.36.0 | 4.39.20 |
github.com/authelia/authelia/v4 Go | From 4.36.0 | 4.39.20 |
github.com/authelia/authelia Go | All versions | None |
How do I fix CVE-2026-48794?
Upgrade github.com/authelia/authelia/v4 to 4.39.20 or later.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-48794 being exploited?
There is no known exploitation of CVE-2026-48794 in the wild and no public exploit code.
Sources
Also known as GHSA-j748-h363-wqj8, GO-2026-5819.