# CVE-2026-48794: Authelia has an Edge Case Access Control Rule Mismatch

> Attackers can bypass access control rules in Authelia by exploiting domain canonicalization flaws in specific forwarded authorization configurations.

- **Severity:** Low 1.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-j748-h363-wqj8, GO-2026-5819

## What is CVE-2026-48794?

CVE-2026-48794 is a low-severity authentication bypass vulnerability in authelia, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Authelia is an open-source authentication and authorization server providing two-factor authentication and single sign-on (SSO) for applications via a web portal. In versions 4.36.0 through 4.39.19, due to lack of canonicalization of domains in very specific edge cases, an access control rule may be skipped when it should match a request. The specific conditions that could lead to a security issue for vulnerability are: 1. The specific target resource of the attack must be using the forwarded authorization integration; 2. The requested domain must have two additional segments compared to a session domain i.e. `a.b.example.com` is requested, but the session domain is `example.com`; 3. There access control rules must specify two separate rules which both contain inexact domain matches such as `*.b.example.com` and `*.example.com` i.e. wildcards, username matches, group matches; 4. The rules must be in order of most specific domain to least specific domain; 5. The second rule must be more permissive than the first rule; 6. The attacker must specifically request a URL for the more specific domain, with the second part containing one or more capitalized letters i.e. `https://a.B.example.com` and no other segment with capitalized letters; 7. The integration used must not be the Envoy ExtAuthz integration; and 8. The proxy must not canonicalize the requested host name in the relevant header before sending it to the relevant authorization endpoint. The kind of configuration used to produce this issue and result in a `bypass` rule being matched has long been highly discouraged. Essentially hosts which should be bypassed entirely should not be secured by having the proxy check them with the authorization handlers. Upgrade to 4.39.20 to receive a patch.

Weakness: CWE-863 (Incorrect Authorization), CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-48794?

4 open source packages ship an affected version, including github.com/authelia/authelia/v4 and github.com/authelia/authelia.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/authelia/authelia/v4` | Go | From 4.36.0 | 4.39.20 |
| `github.com/authelia/authelia/v4` | Go | From 4.36.0 | 4.39.20 |
| `github.com/authelia/authelia/v4` | Go | From 4.36.0 | 4.39.20 |
| `github.com/authelia/authelia` | Go | All versions | None |

## How do I fix CVE-2026-48794?

Upgrade github.com/authelia/authelia/v4 to 4.39.20 or later.

## Is CVE-2026-48794 being exploited?

There is no known exploitation of CVE-2026-48794 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48794 and fix it if it is affected.

What it is: CVE-2026-48794 is a low-severity authentication bypass vulnerability in authelia, published on 19 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48794 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/authelia/authelia/v4 (Go): affected from 4.36.0; fixed in 4.39.20
- github.com/authelia/authelia/v4 (Go): affected from 4.36.0; fixed in 4.39.20
- github.com/authelia/authelia/v4 (Go): affected from 4.36.0; fixed in 4.39.20
- github.com/authelia/authelia (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48794/ (Markdown: https://insights.sbomify.com/CVE-2026-48794/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48794
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48794
- OSV: https://osv.dev/vulnerability/CVE-2026-48794

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48794/
Summaries are generated and may contain mistakes; the official description above is the record.
