# CVE-2026-48799: Postiz: Unauthenticated arbitrary lifetime PRO grant via Nowpayments webhook

> Attackers can grant lifetime PRO subscriptions to arbitrary organizations by bypassing payment verification in the Nowpayments webhook integration.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-j7rp-5mgj-qgg9

## What is CVE-2026-48799?

CVE-2026-48799 is a high-severity vulnerability in gitroomhq postiz-app, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Postiz is an AI social media scheduling tool. Prior to 2.21.8, Postiz fails to verify Nowpayments IPN callback authenticity against the payment provider shared secret and reads the target subscription identifier from the untrusted request body, allowing a low-privileged account to grant arbitrary organizations lifetime PRO subscriptions without payment. This issue is fixed in version 2.21.8.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-48799?


## How do I fix CVE-2026-48799?

No fix has been published for CVE-2026-48799 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-48799 being exploited?

There is no known exploitation of CVE-2026-48799 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48799 and fix it if it is affected.

What it is: CVE-2026-48799 is a high-severity vulnerability in gitroomhq postiz-app, published on 15 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48799 in the wild and no public exploit code.

Affected product: gitroomhq postiz-app. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48799/ (Markdown: https://insights.sbomify.com/CVE-2026-48799/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48799
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48799
- OSV: https://osv.dev/vulnerability/CVE-2026-48799

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48799/
Summaries are generated and may contain mistakes; the official description above is the record.
