# CVE-2026-48801: linkify-it: Quadratic algorithmic complexity in LinkifyIt#match scan loop

> Attackers can cause denial of service in services using linkify-it by sending crafted inputs that trigger quadratic algorithmic complexity.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLEANSTART-2026-DU00914, CLEANSTART-2026-VG66348, CLSA-2026-1791290211, CLSA-2026-1792767578, CLSA-2026-1792776237, ECHO-50e9-36d3-e3c3, GHSA-22p9-wv53-3rq4, MINI-2c73-2chr-v6w3, MINI-324r-924c-p298, MINI-3h5j-vq84-8hhw, MINI-3j3w-65h5-wqq2, MINI-3jfg-7gxx-4cvm, MINI-5wmc-67gj-wqr3, MINI-632c-9vq8-g25p, MINI-6gf7-9m85-w82v, MINI-7hr2-q86m-74h7, MINI-8r3m-9h8f-78j5, MINI-94h3-wj8j-g2q8, MINI-9q75-m629-3w6f, MINI-f7wm-qwm7-96h3, MINI-h7jj-p9v9-mqwg, MINI-hf9m-j4m3-6w43, MINI-hfwv-wm5m-gf35, MINI-jjg8-g5hh-23qp, MINI-jw5g-wj9w-7cqv, MINI-mjw4-c4jh-rhmr, MINI-mv5q-7w76-5jx4, MINI-p587-mmfj-4h42, MINI-pv56-5594-j9wv, MINI-pxr6-388h-gq86, MINI-v4r6-rh4c-6r6f, MINI-vww7-ccww-5hr9, ROOT-APP-NPM-CVE-2026-48801, UBUNTU-CVE-2026-48801

## What is CVE-2026-48801?

CVE-2026-48801 is a high-severity denial of service vulnerability in markdown-it linkify-it, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

linkify-it is a links recognition library with full Unicode support. Prior to 5.0.1, LinkifyIt.prototype.match, the package's primary public API, has O(N²) algorithmic complexity for inputs containing many fuzzy links or emails because the JavaScript-level scan loop re-slices input and re-runs unanchored regex searches on progressively shorter tails. Any service that synchronously renders untrusted Markdown with linkify:true on a request hot path can inherit a worker-process denial of service triggerable by a tens-of-KB request body. This issue is fixed in version 5.0.1.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-48801?

2 open source packages ship an affected version, including linkify-it. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `linkify-it` | npm | All versions | 5.0.1 |
| `linkify-it` | npm | All versions | 5.0.1 |

Products: Markdown-It Linkify-It.

## How do I fix CVE-2026-48801?

Upgrade linkify-it to 5.0.1 or later.

## Is CVE-2026-48801 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48801 exists.

## Other vulnerabilities in markdown-it linkify-it

- [CVE-2026-59887](https://insights.sbomify.com/CVE-2026-59887/): linkify-it: Quadratic-complexity DoS via the `mailto:` validator scan-loop on attacker text (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48801 and fix it if it is affected.

What it is: CVE-2026-48801 is a high-severity denial of service vulnerability in markdown-it linkify-it, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48801 exists.

Affected packages and fixed versions:
- linkify-it (npm): affected all versions; fixed in 5.0.1
- linkify-it (npm): affected all versions; fixed in 5.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48801/ (Markdown: https://insights.sbomify.com/CVE-2026-48801/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48801
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48801
- OSV: https://osv.dev/vulnerability/CVE-2026-48801

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48801/
Summaries are generated and may contain mistakes; the official description above is the record.
