# CVE-2026-48805: Twig: Sandbox state regression in deprecated internal wrappers in `src/Resources/core.php`

> Attackers can bypass Twig sandbox restrictions via deprecated internal wrappers, potentially executing unauthorized code or accessing restricted features.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 16 Jul 2026
- **Also known as:** DEBIAN-CVE-2026-48805, GHSA-p42q-9prx-q5wq, UBUNTU-CVE-2026-48805

## What is CVE-2026-48805?

CVE-2026-48805 is a medium-severity vulnerability in twigphp Twig, published on 14 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Twig is a template language for PHP. Prior to 3.27.0, deprecated internal wrappers in src/Resources/core.php do not forward the current sandbox state to CoreExtension::checkArrow(), arraySome(), and arrayEvery(), allowing legacy calls such as twig_array_some(), twig_array_every(), and twig_check_arrow_in_sandbox() to bypass sandbox callable restrictions. This issue is fixed in version 3.27.0.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-48805?

2 open source packages ship an affected version, including twig/twig. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twig/twig` | Packagist | All versions | 3.27.0 |
| `twig/twig` | Packagist | All versions | 3.27.0 |

Products: Symfony Twig.

## How do I fix CVE-2026-48805?

Upgrade twig/twig to 3.27.0 or later.

## Is CVE-2026-48805 being exploited?

There is no known exploitation of CVE-2026-48805 in the wild and no public exploit code.

## Other vulnerabilities in twigphp Twig

- [CVE-2018-13818](https://insights.sbomify.com/CVE-2018-13818/): Code injection in n/a (critical 9.8)
- [CVE-2026-46633](https://insights.sbomify.com/CVE-2026-46633/): Twig: PHP code injection via `{% use %}` template name (high 8.7)
- [CVE-2026-46640](https://insights.sbomify.com/CVE-2026-46640/): Twig: Arbitrary PHP code execution via `_self.(<string>)` macro-reference compilation (high 8.7)
- [CVE-2026-24425](https://insights.sbomify.com/CVE-2026-24425/): Twig 2.16.x & 3.9.0-3.25.x Sandbox Bypass via SourcePolicyInterface (high 8.7)
- [CVE-2024-45411](https://insights.sbomify.com/CVE-2024-45411/): Twig has a possible sandbox bypass (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48805 and fix it if it is affected.

What it is: CVE-2026-48805 is a medium-severity vulnerability in twigphp Twig, published on 14 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48805 in the wild and no public exploit code.

Affected packages and fixed versions:
- twig/twig (Packagist): affected all versions; fixed in 3.27.0
- twig/twig (Packagist): affected all versions; fixed in 3.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48805/ (Markdown: https://insights.sbomify.com/CVE-2026-48805/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48805
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48805
- OSV: https://osv.dev/vulnerability/CVE-2026-48805

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48805/
Summaries are generated and may contain mistakes; the official description above is the record.
