CVE-2026-48809 python-engineio has possible denial of service due to maximum payload size sometimes not being enforced
Attackers can cause denial of service via memory exhaustion in specific ASGI or Aiohttp configurations by sending oversized payloads that bypass size checks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-48809?
CVE-2026-48809 is a high-severity denial of service vulnerability in miguelgrinberg python-engineio, published on 11 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
python-engineio is a Python implementation of the Engine.IO realtime client and server. Versions prior to 4.13.2 have two specific configurations of the python-engineio server in which the size of incoming messages is not checked before the messages are loaded into memory. An attacker can take advantage of these to cause unnecessary memory allocations in the python-engineio server. The two cases are POST requests, when using ASGI with the long polling transport and WebSocket messages, when using Aiohttp with the WebSocket transport. Version 4.13.2 addresses this issue. ASGI severs now only load the body of incoming requests into memory after the client is confirmed to be known and authenticated, and the payload size is below the maximum allowed size. Requests that do not comply with these requirements are discarded. Aiohttp servers configure the maximum payload size in the underlying WebSocket layer from Aiohttp, so that large messages are discarded by Aiohttp before they are delivered to python-engineio.
Weakness: CWE-770
Which versions are affected by CVE-2026-48809?
3 open source packages ship an affected version, including python-engineio.
| Package | Affected | Fixed in |
|---|---|---|
python-engineio PyPI | All versions | 4.13.2 |
python-engineio PyPI | All versions | 4.13.2 |
python-engineio PyPI | All versions | 4.13.2 |
Linux distribution packages (1)
python-python-engineio openSUSE:Tumbleweed | All versions | 4.13.3-1.1 |
How do I fix CVE-2026-48809?
Upgrade python-engineio to 4.13.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-48809 being exploited?
There is no known exploitation of CVE-2026-48809 in the wild and no public exploit code.
Sources
Also known as DEBIAN-CVE-2026-48809, GHSA-m9gh-vj53-gvh9, PYSEC-2026-3033, ROOT-APP-PYPI-CVE-2026-48809, UBUNTU-CVE-2026-48809, openSUSE-SU-2026:11170-1.