# CVE-2026-48815: sigstore-js: `certificateOIDs` verification constraints are silently dropped and never enforced

> Applications using sigstore-js with certificateOIDs constraints fail to enforce them, allowing acceptance of unauthorized signing certificates.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLEANSTART-2026-AZ47953, CLEANSTART-2026-YO55047, CLEANSTART-2026-ZU97983, CLSA-2026-1791840004, CLSA-2026-1792582435, GHSA-52v5-jr5w-gjxr, MINI-3ffx-ppx9-53qm, MINI-53jx-p9pj-2m68, MINI-8q5j-7c9p-9qjg, MINI-h3rr-pvpp-pc4f, MINI-jm4c-xmhp-cf6x, MINI-qvw5-9wcf-9622, MINI-wcg2-r8pc-fqwj, ROOT-APP-NPM-CVE-2026-48815

## What is CVE-2026-48815?

CVE-2026-48815 is a high-severity vulnerability in sigstore-js, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

sigstore-js provides JavaScript libraries for interacting with Sigstore services. Prior to 4.1.1, the documented certificateOIDs option in sigstore.verify() is accepted by the public API but discarded before verification, so required certificate extension OIDs are never checked and applications relying on certificateOIDs to restrict which certificates may sign artifacts can accept unauthorized certificates. This issue is fixed in version 4.1.1.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-48815?

2 open source packages ship an affected version, including sigstore.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sigstore` | npm | All versions | 4.1.1 |
| `sigstore` | npm | All versions | 4.1.1 |

## How do I fix CVE-2026-48815?

Upgrade sigstore to 4.1.1 or later.

## Is CVE-2026-48815 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48815 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48815 and fix it if it is affected.

What it is: CVE-2026-48815 is a high-severity vulnerability in sigstore-js, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48815 exists.

Affected packages and fixed versions:
- sigstore (npm): affected all versions; fixed in 4.1.1
- sigstore (npm): affected all versions; fixed in 4.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48815/ (Markdown: https://insights.sbomify.com/CVE-2026-48815/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48815
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48815
- OSV: https://osv.dev/vulnerability/CVE-2026-48815

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48815/
Summaries are generated and may contain mistakes; the official description above is the record.
