CVE-2026-48816 sigstore-js: Insufficient Verification of Data Authenticity
Attackers can manipulate certificate validity and timestamp checks in sigstore-js by supplying untrusted bundles, bypassing data authenticity verification.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-48816?
CVE-2026-48816 is a medium-severity vulnerability in sigstore-js, published on 14 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
sigstore-js provides JavaScript libraries for interacting with Sigstore services. Prior to 3.1.1, @sigstore/verify derives a transparency-log timestamp from tlogEntries[].integratedTime for bundle v0.2 inclusionProof-only entries even though the inclusion proof path does not cryptographically bind integratedTime, allowing an attacker who can supply an untrusted bundle to influence certificate validity and timestampThreshold verification decisions. This issue is fixed in version 3.1.1.
Weakness: CWE-345
Which versions are affected by CVE-2026-48816?
2 open source packages ship an affected version, including @sigstore/verify.
| Package | Affected | Fixed in |
|---|---|---|
@sigstore/verify npm | From 3.1.0 | 3.1.1 |
@sigstore/verify npm | From 3.1.0 | 3.1.1 |
How do I fix CVE-2026-48816?
Upgrade @sigstore/verify to 3.1.1 or later.
Is CVE-2026-48816 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48816 exists.
Sources
Also known as CLEANSTART-2026-CI36044, CLEANSTART-2026-FX79373, GHSA-xgjw-pm74-86q4, MINI-395r-q29h-26fm, MINI-7px9-hq5x-xmj2, MINI-mgv9-6769-gvvv and 3 more.