# CVE-2026-48816: sigstore-js: Insufficient Verification of Data Authenticity

> Attackers can manipulate certificate validity and timestamp checks in sigstore-js by supplying untrusted bundles, bypassing data authenticity verification.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** CLEANSTART-2026-CI36044, CLEANSTART-2026-FX79373, GHSA-xgjw-pm74-86q4, MINI-395r-q29h-26fm, MINI-7px9-hq5x-xmj2, MINI-mgv9-6769-gvvv, MINI-q6qc-7gcc-fqqw, MINI-xq2f-358v-pcvx, ROOT-APP-NPM-CVE-2026-48816

## What is CVE-2026-48816?

CVE-2026-48816 is a medium-severity vulnerability in sigstore-js, published on 14 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

sigstore-js provides JavaScript libraries for interacting with Sigstore services. Prior to 3.1.1, @sigstore/verify derives a transparency-log timestamp from tlogEntries[].integratedTime for bundle v0.2 inclusionProof-only entries even though the inclusion proof path does not cryptographically bind integratedTime, allowing an attacker who can supply an untrusted bundle to influence certificate validity and timestampThreshold verification decisions. This issue is fixed in version 3.1.1.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity)

## Which versions are affected by CVE-2026-48816?

2 open source packages ship an affected version, including @sigstore/verify.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sigstore/verify` | npm | From 3.1.0 | 3.1.1 |
| `@sigstore/verify` | npm | From 3.1.0 | 3.1.1 |

## How do I fix CVE-2026-48816?

Upgrade @sigstore/verify to 3.1.1 or later.

## Is CVE-2026-48816 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48816 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48816 and fix it if it is affected.

What it is: CVE-2026-48816 is a medium-severity vulnerability in sigstore-js, published on 14 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48816 exists.

Affected packages and fixed versions:
- @sigstore/verify (npm): affected from 3.1.0; fixed in 3.1.1
- @sigstore/verify (npm): affected from 3.1.0; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48816/ (Markdown: https://insights.sbomify.com/CVE-2026-48816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48816
- OSV: https://osv.dev/vulnerability/CVE-2026-48816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48816/
Summaries are generated and may contain mistakes; the official description above is the record.
