# CVE-2026-48818: Starlette: SSRF and NTLM credential theft via UNC paths in StaticFiles on Windows

> Attackers can trigger SSRF and steal NTLM credentials via UNC paths in Starlette StaticFiles on Windows, affecting default configurations.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 4 Aug 2026
- **Also known as:** CLEANSTART-2026-EH91942, CLEANSTART-2026-GY64291, ECHO-e56a-8ef3-f017, GHSA-wqp7-x3pw-xc5r, MINI-2wgq-m46h-g8h8, MINI-34qp-cvjp-8jf7, MINI-37v3-hg9f-p3xf, MINI-5f34-qm5f-73qp, MINI-6ghv-jmfw-hv78, MINI-7h8w-jjw4-3rfx, MINI-8rmx-wh3c-xx86, MINI-8wmm-vc97-9xjw, MINI-96gq-6qjx-33p3, MINI-9v3c-p39h-j472, MINI-ffph-jp34-r68x, MINI-fx67-qfx3-c4pm, MINI-hw84-84v8-x9qj, MINI-m45m-47x7-4gpm, MINI-wj5v-r5jj-6868, PYSEC-2026-2281, ROOT-APP-PYPI-CVE-2026-48818, UBUNTU-CVE-2026-48818, openSUSE-SU-2026:11572-1

## What is CVE-2026-48818?

CVE-2026-48818 is a high-severity server-side request forgery vulnerability in Kludex starlette, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Starlette is a lightweight ASGI framework/toolkit. In versions 1.0.1 and earlier, StaticFiles on Windows is vulnerable to SSRF. An UNC path such as \\attacker.com\share can cause os.path.realpath to initiate an outbound SMB connection before the path is rejected, exposing the service account’s NTLMv2 credentials for offline cracking or relay even though the HTTP response is only a 404. The issue affects default follow_symlink=False deployments, including frameworks built on Starlette such as FastAPI; POSIX systems and follow_symlink=True are unaffected. The issue is fixed in 1.1.0.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-48818?

3 open source packages ship an affected version, including starlette. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `starlette` | PyPI | All versions | 1.1.0 |
| `starlette` | PyPI | All versions | 1.1.0 |
| `starlette` | PyPI | All versions | 1.1.0 |
| `python-graphifyy` | openSUSE:Tumbleweed | All versions | 0.9.48-1.1 |

Products: Encode Starlette.

## How do I fix CVE-2026-48818?

Upgrade starlette to 1.1.0 or later.

## Is CVE-2026-48818 being exploited?

There is no known exploitation of CVE-2026-48818 in the wild and no public exploit code.

## Other vulnerabilities in Kludex starlette

- [CVE-2026-48710](https://insights.sbomify.com/CVE-2026-48710/): Kludex Starlette HTTP Request/Response Smuggling (medium 6.5, exploited in the wild)
- [CVE-2026-54283](https://insights.sbomify.com/CVE-2026-54283/): Starlette: request.form() limits silently ignored for application/x-www-form-urlencoded enable DoS (high 7.5)
- [CVE-2023-29159](https://insights.sbomify.com/CVE-2023-29159/): Starlette has Path Traversal vulnerability in StaticFiles (high 7.5)
- [CVE-2023-30798](https://insights.sbomify.com/CVE-2023-30798/): MultipartParser DOS with too many fields or files in Starlette Framework (high 7.5)
- [CVE-2026-48817](https://insights.sbomify.com/CVE-2026-48817/): Starlette: Arbitrary HTTP method dispatched to `HTTPEndpoint` attributes via `getattr` (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48818 and fix it if it is affected.

What it is: CVE-2026-48818 is a high-severity server-side request forgery vulnerability in Kludex starlette, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48818 in the wild and no public exploit code.

Affected packages and fixed versions:
- starlette (PyPI): affected all versions; fixed in 1.1.0
- starlette (PyPI): affected all versions; fixed in 1.1.0
- starlette (PyPI): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48818/ (Markdown: https://insights.sbomify.com/CVE-2026-48818/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48818
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48818
- OSV: https://osv.dev/vulnerability/CVE-2026-48818

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48818/
Summaries are generated and may contain mistakes; the official description above is the record.
