# CVE-2026-48819: Hey API: `buildClientParams` template: prototype chain substitution via unknown `$<slot>___proto__` key


- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 17 Jul 2026
- **Updated:** 20 Jul 2026
- **Also known as:** GHSA-hhx9-57xq-r5rw

## What is CVE-2026-48819?

CVE-2026-48819 is a medium-severity vulnerability in hey-api openapi-ts, published on 17 Jul 2026. 

### Official description

Hey API is an ecosystem for turning API specifications into production-ready code. Prior to 0.97.3, dist/clients/core/params.ts ships a runtime template copied into generated SDKs as params.gen.ts, and buildClientParams writes unknown slot-prefixed keys such as $body_, $headers_, $path_, and $query_ directly to the corresponding slot, allowing $query___proto__ alongside a legitimate q field to set params.query through params["query"]["__proto__"] = value, call Object.setPrototypeOf(params.query, value), and expose inherited attacker-controlled keys during for..in iteration. This issue is fixed in version 0.97.3.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2026-48819?

2 open source packages ship an affected version, including @hey-api/openapi-ts.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hey-api/openapi-ts` | npm | All versions | 0.97.3 |
| `@hey-api/openapi-ts` | npm | All versions | 0.97.3 |

## How do I fix CVE-2026-48819?

Upgrade @hey-api/openapi-ts to 0.97.3 or later.

## Is CVE-2026-48819 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48819 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48819 and fix it if it is affected.

What it is: CVE-2026-48819 is a medium-severity vulnerability in hey-api openapi-ts, published on 17 Jul 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-48819 exists.

Affected packages and fixed versions:
- @hey-api/openapi-ts (npm): affected all versions; fixed in 0.97.3
- @hey-api/openapi-ts (npm): affected all versions; fixed in 0.97.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48819/ (Markdown: https://insights.sbomify.com/CVE-2026-48819/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48819
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48819
- OSV: https://osv.dev/vulnerability/CVE-2026-48819

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48819/
Summaries are generated and may contain mistakes; the official description above is the record.
