# CVE-2026-48828: Apache Airflow: Bulk JSON Variables bypass should_hide_value_for_key - redact() called without the key

> Authenticated users can retrieve plaintext secrets from JSON variables due to missing key-based redaction checks in the Bulk Variables API.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 16 Sep 2026
- **Also known as:** BIT-airflow-2026-48828, CLEANSTART-2026-TQ39648, ECHO-2431-3a02-f2b2, GHSA-563f-2439-rmq4, MINI-8rgj-f3pj-fpc6, MINI-jc59-xvr5-wj92, PYSEC-2026-3806

## What is CVE-2026-48828?

CVE-2026-48828 is a medium-severity vulnerability in Apache Airflow, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Bulk Variables API in Apache Airflow called the redactor without passing the variable's key, so the key-based `should_hide_value_for_key` check (which triggers on secret-suffixed key names like `*_password` / `*_token` / `*_secret`) could not fire for JSON-decodable variable values. An authenticated UI/API user with bulk Variable read permission could retrieve plaintext values from JSON variables whose key would otherwise trigger redaction. Affects deployments that store sensitive values in JSON-typed Airflow Variables under secret-suffixed key names. Users are advised to upgrade to `apache-airflow` 3.3.0 or later (the fix landed on `main` after 3.2.2; no 3.2.x backport).

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-48828?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.3.0 |
| `apache-airflow` | PyPI | All versions | 3.3.0 |
| `apache-airflow` | PyPI | All versions | 3.3.0 |
| `airflow` | Bitnami | All versions | 3.3.0 |

Products: Apache Airflow.

## How do I fix CVE-2026-48828?

Upgrade apache-airflow to 3.3.0 or later.

## Is CVE-2026-48828 being exploited?

There is no known exploitation of CVE-2026-48828 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48828 and fix it if it is affected.

What it is: CVE-2026-48828 is a medium-severity vulnerability in Apache Airflow, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48828 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.3.0
- apache-airflow (PyPI): affected all versions; fixed in 3.3.0
- apache-airflow (PyPI): affected all versions; fixed in 3.3.0
- airflow (Bitnami): affected all versions; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48828/ (Markdown: https://insights.sbomify.com/CVE-2026-48828/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48828
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48828
- OSV: https://osv.dev/vulnerability/CVE-2026-48828

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48828/
Summaries are generated and may contain mistakes; the official description above is the record.
