# CVE-2026-48830: Apache bRPC: HTTP builtin request can mark a connection authenticated and bypass auth for later requests


- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-7758-m63q-7vr5

## What is CVE-2026-48830?

CVE-2026-48830 is a vulnerability in Apache bRPC, published on 21 Oct 2026. 

### Official description

Improper authentication in Apache bRPC through 1.17.0 allows a remote unauthenticated attacker to bypass authentication for protected non-builtin HTTP endpoints by first sending a builtin HTTP request on the same HTTP/1.1 keep-alive connection.

When ServerOptions.auth is enabled and builtin HTTP services are exposed on the public listener, a builtin request received as the first message on a socket may cause the connection to be treated as authenticated for later requests on that socket. Users are recommended to upgrade to version 1.18.0, which fixes this issue, or apply this PR separately:  https://github.com/apache/brpc/pull/3308

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-48830?


## How do I fix CVE-2026-48830?

No fix has been published for CVE-2026-48830 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-48830 being exploited?

There is no known exploitation of CVE-2026-48830 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48830 and fix it if it is affected.

What it is: CVE-2026-48830 is a vulnerability in Apache bRPC, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-48830 in the wild and no public exploit code.

Affected product: Apache bRPC. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48830/ (Markdown: https://insights.sbomify.com/CVE-2026-48830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48830
- OSV: https://osv.dev/vulnerability/CVE-2026-48830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48830/
Summaries are generated and may contain mistakes; the official description above is the record.
