CVE-2026-48834 Apache Answer: Denial of service via crafted Accept-Language header parsing

High 7.5 Published Updated

Unauthenticated attackers can cause denial of service in Apache Answer via a crafted Accept-Language header causing excessive CPU consumption.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-48834?

CVE-2026-48834 is a high-severity denial of service vulnerability in Apache Answer, published on 5 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper Handling of Length Parameter Inconsistency vulnerability in Apache Answer.

This issue affects Apache Answer: through 2.0.1.

Unauthenticated attackers can cause a denial of service via a specially crafted Accept-Language header that triggers excessive CPU consumption during parsing. Users are recommended to upgrade to version 2.0.2, which fixes the issue.

Weakness: CWE-400

Which versions are affected by CVE-2026-48834?

It affects 1 product.

Products include Apache Answer.

How do I fix CVE-2026-48834?

No fix has been published for CVE-2026-48834 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-48834 being exploited?

There is no known exploitation of CVE-2026-48834 in the wild and no public exploit code.

Sources

Also known as GHSA-9mxc-x85j-v2wc.

Is CVE-2026-48834 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free