# CVE-2026-48891: Apache Airflow exposes unreadable DAG identifiers in the scheduling dependencies graph

> Authenticated users can enumerate unauthorized DAG identifiers via dependency graph fields, leaking private workflow names in Apache Airflow.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 16 Sep 2026
- **Also known as:** BIT-airflow-2026-48891, CLEANSTART-2026-AK03050, CLEANSTART-2026-WT65883, ECHO-fc1c-ad29-231d, GHSA-3322-mjxh-9mp5, MINI-488q-23mg-49q8, MINI-qr79-27xj-wwgf, PYSEC-2026-2086

## What is CVE-2026-48891?

CVE-2026-48891 is a medium-severity vulnerability in Apache Airflow, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A bug in Apache Airflow's `/ui/dependencies` scheduling graph endpoint applied the caller's readable-Dag filter to the top-level serialized Dag key but still emitted referenced Dag IDs through the `dep.source` and `dep.target` fields of trigger / sensor dependency entries. An authenticated UI user with read permission on some Dags could enumerate the identifiers of other Dags they were not authorized to read by inspecting the dependency graph for trigger / sensor references. Affects deployments that rely on per-Dag read scoping to keep Dag identifiers private across teams. This is a residual gap in the fix for CVE-2026-28563, which filtered the top-level Dag key but did not propagate the filter into the trigger / sensor dep-source / dep-target fields. Users who already upgraded for CVE-2026-28563 should additionally upgrade to `apache-airflow` 3.3.0 or later to cover the residual trigger / sensor dependency leak.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-48891?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.3.0 |
| `apache-airflow` | PyPI | All versions | 3.3.0 |
| `apache-airflow` | PyPI | All versions | 3.3.0 |
| `airflow` | Bitnami | All versions | 3.3.0 |

Products: Apache Airflow.

## How do I fix CVE-2026-48891?

Upgrade apache-airflow to 3.3.0 or later.

## Is CVE-2026-48891 being exploited?

There is no known exploitation of CVE-2026-48891 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48891 and fix it if it is affected.

What it is: CVE-2026-48891 is a medium-severity vulnerability in Apache Airflow, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48891 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.3.0
- apache-airflow (PyPI): affected all versions; fixed in 3.3.0
- apache-airflow (PyPI): affected all versions; fixed in 3.3.0
- airflow (Bitnami): affected all versions; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48891/ (Markdown: https://insights.sbomify.com/CVE-2026-48891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48891
- OSV: https://osv.dev/vulnerability/CVE-2026-48891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48891/
Summaries are generated and may contain mistakes; the official description above is the record.
