# CVE-2026-48892: Apache Airflow: Config API leaks per-key secrets backend kwargs - masker bypass on synthetic options

> Authenticated users can retrieve plaintext secrets-backend credentials from the Config API due to a masker bypass in Apache Airflow.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2026
- **Updated:** 16 Sep 2026
- **Also known as:** BIT-airflow-2026-48892, CLEANSTART-2026-XI09971, ECHO-b7b3-43e2-69ff, GHSA-9933-5rrp-mfwx, MINI-j587-q88j-48q6, MINI-w2vp-496v-hqmw, PYSEC-2026-2087

## What is CVE-2026-48892?

CVE-2026-48892 is a medium-severity vulnerability in Apache Airflow, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Config API in Apache Airflow surfaced per-key secrets-backend overrides (environment variables like `AIRFLOW__SECRETS__BACKEND_KWARG__SECRET_ID` and `AIRFLOW__WORKERS__SECRETS_BACKEND_KWARG__SECRET_ID`) as synthetic config options whose option names were not in `sensitive_config_values`, so the masker did not redact them. An authenticated UI/API user with Config read permission could retrieve plaintext secrets-backend credentials (Vault `role_id` / `secret_id`, etc.) from the Config API output. Affects deployments that configure secrets backends via per-key environment overrides. Users are advised to upgrade to `apache-airflow` 3.3.0 or later.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-48892?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 3.3.0 |
| `apache-airflow` | PyPI | All versions | 3.3.0 |
| `apache-airflow` | PyPI | All versions | 3.3.0 |
| `airflow` | Bitnami | All versions | 3.3.0 |

Products: Apache Airflow.

## How do I fix CVE-2026-48892?

Upgrade apache-airflow to 3.3.0 or later.

## Is CVE-2026-48892 being exploited?

There is no known exploitation of CVE-2026-48892 in the wild and no public exploit code.

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-48892 and fix it if it is affected.

What it is: CVE-2026-48892 is a medium-severity vulnerability in Apache Airflow, published on 7 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-48892 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 3.3.0
- apache-airflow (PyPI): affected all versions; fixed in 3.3.0
- apache-airflow (PyPI): affected all versions; fixed in 3.3.0
- airflow (Bitnami): affected all versions; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-48892/ (Markdown: https://insights.sbomify.com/CVE-2026-48892/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-48892
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-48892
- OSV: https://osv.dev/vulnerability/CVE-2026-48892

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-48892/
Summaries are generated and may contain mistakes; the official description above is the record.
