CVE-2026-48895 Apache APISIX: Cas-auth Host header influence on CAS service URL
Attackers can manipulate headers to redirect users to malicious sites, potentially exposing session tokens in Apache APISIX.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-48895?
CVE-2026-48895 is a low-severity vulnerability in Apache APISIX, published on 19 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
URL Redirection to Untrusted Site ('Open Redirect') vulnerability in Apache APISIX.
The attacker could manipulate some client headers to perform an open-redirect, to potentially expose the session token.
This issue affects Apache APISIX: from 3.0.0 through 3.16.0.
Users are recommended to upgrade to version 3.17.0, which fixes the issue.
Weakness: CWE-601
Which versions are affected by CVE-2026-48895?
1 open source package ship an affected version, including apisix. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apisix Bitnami | From 3.0.0 | 3.17.0 |
Products include Apache Apisix.
How do I fix CVE-2026-48895?
Upgrade apisix to 3.17.0 or later.
Is CVE-2026-48895 being exploited?
There is no known exploitation of CVE-2026-48895 in the wild and no public exploit code.
Other vulnerabilities in Apache APISIX
- CVE-2022-24112 Apache APISIX Authentication Bypass
- CVE-2022-25757 Apache APISIX: the body_schema check in request-validation plugin can be bypassed
- CVE-2026-31908 Apache APISIX: forward auth plugin allows header injection
- CVE-2026-75005 Apache APISIX: Unauthenticated CPU-exhaustion DoS
- CVE-2025-27446 Privilege escalation in Apache APISIX Java Plugin Runner
Sources
Also known as BIT-apisix-2026-48895, GHSA-q562-qrm6-7p84, MINI-gmrj-g66c-v9f8.