CVE-2026-48910 Apache JSPWiki: Markdown parser allows XSS injection in Markdown error processing

Medium 6.5 Published Updated

Attackers can inject JavaScript via crafted Markdown editing requests in Apache JSPWiki, leading to XSS and potential data theft.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-48910?

CVE-2026-48910 is a medium-severity cross-site scripting vulnerability in Apache JSPWiki, published on 30 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A carefully crafted editing request could trigger an XSS vulnerability on Apache JSPWiki when parsing errors on the markdown renderer, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim.

This issue affects Apache JSPWiki: through 2.12.3.

Users are recommended to upgrade to version 2.12.4, which fixes the issue.

Weakness: CWE-80

Which versions are affected by CVE-2026-48910?

It affects 1 product.

Products include Apache Jspwiki.

How do I fix CVE-2026-48910?

No fix has been published for CVE-2026-48910 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-48910 being exploited?

There is no known exploitation of CVE-2026-48910 in the wild and no public exploit code.

Sources

Also known as GHSA-g956-w8r6-2m72.

Is CVE-2026-48910 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free